Belkin Wireless G+ settings.

  Analyst02 22:08 25 Feb 2008
Locked

Hi folks,

Have today been out and bought a Belkin G+ notebook card for my laptop.

I installed the software and connected the card as asked to and installation went through without any hitches.

Looking at the Belkin wireless networking utlilty it sees my network fine. However When i click on connect i get a small text box saying "connect to a secure network"
The encryption key box is blank and underneath that is my SSID. The option to connect is still there so i click on it again and i get an error saying "please choose a valid certificate".

As stated its a Belkin G+ notebook card. The router is a Netgear dg834g v3

I dont have a clue about this, Can any kind hearted soul help me out please?

Compaq presario 2500
win xp pro
950 mb ram
1.8 ghz cpu

  brundle 23:44 25 Feb 2008

What version of Windows, and are you using Belkin's wireless management software?

  brundle 23:45 25 Feb 2008

Sorry, you posted Windows version already

  Analyst02 23:53 25 Feb 2008

Hi Brundle.

Yes im letting Belkin do all the work, as i say seemed to go through ok.

Just when i click on connect to my network it is asking for a valid certificate! If i select 'valid server certificate' i get a list of atleast 100 trusted certificates, no matter which one i choose.. i still get the same error "please choose a valid certificate" ..

Regards

  brundle 00:17 26 Feb 2008

Disable the Belkin wireless management software, the built-in XP software is generally simpler and better.
Certificate should only be required for connecting to a domain or secure sites, or perhaps a RADIUS server.

  Analyst02 00:30 26 Feb 2008

Ok brundle.

Sorted, Jobs a goodun.

So much for the Belkin "management" software eh

Many thanks for your assistance.

Kind regards to you.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?