Belkin Wireless G Router video streaming problems

  jonigiro 16:00 19 Feb 2008


I bought a belkin wireless G router a couple of weeks ago and have been having a problem with video streaming and downloading large files, it stops after a couple of minutes and says buffering but never gets any futher and with downloading large files it downloads at a normal speed for the first minute or two then the speed drops to zero. I tried updating the firmware via the belkin web site and this solved the problem but then when switched on the coputer and router the next day the problem was back again, I once again. I have tried updating the firmware again which again sorted the problem only for it to come back after I had powered down and restarted everything. I was wondering if it is a problem with the router not storing the firmware upgrade or is it something else?

I am using a laptop with a 2meg virgin media broadband connection which works fine when it is connected straight to the modem.

Many thanks in advance


  brundle 18:25 19 Feb 2008

What version of Windows? What Belkin model number, there is an issue with a couple of specific Belkin models. Connection via USB adapter?

  jonigiro 15:10 20 Feb 2008

Hi I am using windows XP sp2 with a internal 802.11g wireless carbus adapter and a belkin wireless G router model number: F5D7230-4.


  brundle 22:12 20 Feb 2008

Have you tried it using a cable connection from router to laptop?

  jonigiro 09:10 22 Feb 2008

I tried connecting the router directly to the laptop using an ethernet cabel last night and was able to stream videos perfectly. Although this solved the problem the reason for buying the wireless router was so I didn't have wires going accross the room. Could it be a compatability issue between the wireless card and router? cheers

  conan_troutman 13:35 23 Feb 2008

ideally for video streaming you would want a N router, as the G router may not be able to handle the amount of data over a distance larger tha you living room.

  ciklin 10:21 15 May 2008

Hi Joni

Have u solve the problem? I was looking for any solution for such problem. Now I cannot even watch any youtube video for say more than 10 mins. It will stop and doesnt say any error message or even buffering msg. Any advice?

  lovetorpedo 20:59 22 May 2008

i had this problem and i changed the connection type on the router menu - something about the ip address changing. change it from 'dynamic' i think it is to the option underneath :)

  User-1229748 13:28 23 May 2008

i know it doesn't help you but might help others this is the reason i had virgin cable taken up to my bedroom even though i could have had a free wireless router.The ethernet connection is so much better.Hope you get your problem sorted.

  z522 18:44 15 Sep 2008

I also recently had this problem. I managed to fix this problem, i dont know if it could be the same but its worth a try.If you go to the router webpage which is click here on the left hand menu in the wireless section select channel and SSID. Default password is blank, when you get to this page change your channel number and see if this has made any difference keep trying different channels until one works. I changed mine from auto to 1 and this fixed the problem for me. I also extented my range, enabled protection and turbo mode not sure whether that helped but did it anyway

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?