Belkin Wireless F5D7050B Problems

  anonymous987 20:44 18 Jul 2006


Please can you help where belkin customer support have failed.

I have recently bought a wireless g USB adaptor F5D7050B, which works fine on my desktop PC, by following the instructions it came with.

However, for some reason I cannot install the same adaptor on my laptop, using the same procedure.

The install procedure gets to the very last screen which then says:

Cannot install this hardware
There was a problem installing this hard ware
Belkin 54g Wireless USB Network Adapter
An error occured during the installation of the device
The system cannot find the file specified.

Belkins diagnosis, and mine, is that the laptop (or the software on it) is at fault as the same procedure works on 2 other PCs.

So the question is, what is different on the laptop to the desktop that is making it not work?

Belkin suggested USB ports on laptop at fault, but i doubt this as they work fine when using other hardware.

I have tried automatic & manual install, both with the same results.

Desktop running :
XP Professional 2002 service pack 2.
Athlon XP 2600

XP Home 2002 service pack 2.
Celeron 1.5Ghz

If it is a clue, the only difference between the sequence of install screens, is that the desktop displays the "The sofwtare you are installing has not passed windows logo testing to verify its compatibility with windows xp, Continue Anyway, Stop Installation" screen during installation, whereas the laptop does not.

Anyone any ideas?

Many Thanks in advance

  ade.h 20:57 18 Jul 2006

Here's how to install a USB wireless receiver with Windows XP - tell me whether you are following these steps:

1) Boot up, log in and insert the driver CD.
2) CANCEL the CD window! It MUST NOT be running.
3) Plug in the adapter and wait for the New Hardware Found wizard.
4) Point the wizard to your optical drive in its search for a device driver. Complete the wizard.
5) Reboot, with the device plugged in.
6) Connect to your wireless LAN by single-clicking on the WLAN icon in the Notification Area, refreshing the network list, choosing your network SSID and connecting to it.
7) Enter the WPA-PSK if you have enabled that feature and create a firewall permission if/when your software firewall prompts you.


  anonymous987 09:26 19 Jul 2006

Thanks for your reply.
Yes I have followed steps 1 to 4 extactly as you describe. However, I cannot complete step 4 as the very last screen of the wizard gives me the file not found messaage. It doesn't specify which file is not found. It isn't the rt73.inf file that is missing as this is the file I have pointed it to. After I've pointed it to rt73.inf, it copies a whole load of files off the cd, and then the file not found error message. The driver cd works fine on other pcs. Also I have downloaded latest driver from belkin website, which gives the same error message.


  nob14 13:57 19 Jul 2006

Its something to do with the USB ports on the laptop.

Anything odd in device manager about the ports?

  anonymous987 21:55 19 Jul 2006

Thanks for the idea. I've had a look

No problems with the ports themselves at all.

When I put the adaptor in for first time i get code 22 - e.g. needs enabling

afer enabling - i get code 18 e.g. driver needs reinstalling

after installing drivers (but wizard gets stuck at last stage) i get code 28 - e.g. drive not installed

Hope this helps diagnose problem



  nob14 21:48 20 Jul 2006

I dont know if it matters but are the ones that work USB2 and the laptop 1

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017