Belkin USB 2 PCI card will not install.

  Pappyon 17:34 07 Jul 2004
Locked

I have followed the instructions to the letter in the instruction manual, but nothing is showing up under USB controllers.
I am running Win XP with SPI.
I have tried installing it using the supposedly installed SPI drivers, that didn't work so I installed the drivers on the installation CD ROM.
I have tried physically uninstalling the card and reinstalling it and still no luck.

It is as though I had not installed a PCI card at all. There is no sign anywhere of the software or the hardware having been installed.

I have tried installing the card under device manager. I have tried everything I can think of.

Please help me. It's beginning to get to me!!

  Djohn 17:57 07 Jul 2004

If you remove the PCI card and reboot then turn off, insert the card again and re-boot does the "Found new hardware wizard" kick into action?

Sorry for starting with the basics but seeing as you've tried quite a few things already I thought it best to start again in case you may have missed something then someone may pick up on what is wrong. j.

  Pappyon 18:03 07 Jul 2004

I thank you very much for your almost instant response. I have alread tried what you advocated with no results.

If I could simplify things, as I am not the brightest. It's as though I had never even opened the case of my PC, and normally when I install software it shows up in Control Panel/Add or Remove. There is nothing showing anwhere in relation to having installed the drivers from the CD ROM!

  Djohn 18:11 07 Jul 2004

Your welcome Pappyon. Unfortunately I'm going out for a couple of hours but will be back later. Meanwhile can you post the make/model of your motherboard so that others will be able to run a check to make sure it will support the card, it may also be something in the BIOS that needs a tweak j.

  norman47 18:14 07 Jul 2004

Have you tried different PCI slots, if you have more than one PCI slot spare.

  Pappyon 18:25 07 Jul 2004

I will try that.

Djohn
I have an ASUS A7A266 Socket motherboard.
I also updated (flashed) the BIOS to V1011 if you require that information. It worked due more to luck than to any skill or experience I have.

I have a very funny feeling I have installed a USB 2 PCI card about a year ago by mistake (don't laugh) thinking it was a PCI modem. I took it back to Argos and got a refund.

I think I may have installed it in a different slot also if I can remember correctly.

  Pappyon 18:43 07 Jul 2004

norman 47
It installed no bother in another slot. Could you please explain to a numpty why it is the case that it wouldn't install on the first slot I tried.

I thank you both very much again!!

  norman47 18:58 07 Jul 2004

Will try, but a bit unsure myself. lol

First of all every PCI slot has a IRQ, known as an interrupt request allocation. This basically means that it has a pecking order to the memory,motherboard and cpu. So each PCI slot has this, this is then complicated by the chipset of the PCI card which asks for it's address to be inserted in the pecking order, some times it tries to muscle in this can cause memory conflicts and blue screens. The software for the peripheral re-enforces the interrupt request. Windows x\p has done away with a lot of IRQ memory request problems by using virtual IRQ's, these are clones of the original IRQ. The memory request( range)or IRQ in one slot may conflict with a particular pci slot, so shifting it to another may bring the memory range to an acceptable range.

I think the above statement may be a load of rubbish, but that's how I see it.

Bluntly put if it won't work in one, bung it in another.:-)

  Pappyon 19:06 07 Jul 2004

Well ah yes exactly, um, erm, erm. I understand that perfectly! I did get a blue screen twice by the way trying to install on the first slot.

I am much obliged to you again.

All the best to you.

  jakimo 19:23 07 Jul 2004

Just checking!

You did install the belkin software before fitting the usb card?

I ask because I have the same card as you and it wasn't recognized unless the drivers were loaded,pc switched off\fitted card and rebooted

  jack 19:46 07 Jul 2004

When fol have trouble installing a piece of hardware. the problem can be cause by contflicts caused by leaving the Anti Virus, Firwall running. Shut it all down.
To this end these is out there some where a useful utility called 'End It All'
This shuts allrunnig programs down and lease
Windos all ready to see wht you have to offer.
A Google should locate the software I meanwhile will look it up in mu utilites file and come back

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

50 best online Adobe XD tutorials

iPad Pro 10.5in (2017) review

Comment connecter un MacBook à une TV ?