Belkin pre-N PCI adapter Installation Problem

  Danoh 03:34 19 Feb 2006

NTL Cable standalone modem, Belkin pre-N Router, XP Media Centre (Evesham Axis RD Plus).

Setup WPA-PSK (TKIP encryption), MAC addressing with no problems on router. Got great range and signal strength with 802.11g on Sony laptop and D-Link USB adapter for desktop (both XP home).

But when I try to install a pre-N PCI Desktop adapter the Media Center desktop, I get stuck when the installation routine prompts me to insert the pre-N PCMIA card into the PCI adapter.

The PC freezes and either no input (mouse / keyboard) works or there is no reaction when I click on "Next" after inserting the PCMIA card.

The PCMIA card's LEDs do not light up either.

I must be doing something wrong? All suggestions appreciated!

Many thanks in anticipation.

  welshwizard712 17:07 19 Feb 2006


Is the card Media Center compatible?

Maybe a dodgy PCI Slot, Try Another?

Then last Faulty Card, Return and Get a New One



  Danoh 18:23 19 Feb 2006

There's no specification of compatibility but I presume XP also covers XP Media Center 2005; will try and contact the vendor and/or Belkin.

Although a new PC & motherboard, I did try the 2nd PCI slot (as opposed to the PCI Express x16 and x1 slots!).

I have two PCI adapters and notebook cards so I have tried them both with the same result. I'd be very surprised if both are faulty.

Thanks for the suggestions; I've downloaded an XP driver and will try to use that instead of the Installation CD.

  Danoh 19:06 19 Feb 2006

Same result with the downloaded Belkin XP driver. Either both the PCI cards are faulty or the PCI slots-MoBo is not functioning.

Frustrating as the non pre-N channels are working perfectly using a D-Link USB adapter and the built-in laptop's 802.11g capability.

WPA-PSK, SSID non-broadcast, MAC address filtered, network file transfer, internet access, all working. Was hoping to have finished and tidied all away before the weekend is over <sigh>

  keewaa 19:32 19 Feb 2006

Whats the model numbers of the devices ... i suggest you try google search of "model number windows media installation" and see if there is any advice.

  Danoh 12:45 20 Feb 2006

PCI desktop adaptor (F5D8000-4) is a cradle into which the PCMCIA card (included) F5D8010 is inserted. {not related to this issue, but the Router is F5D8320-4)

When I tried another PCI (modem) card, Windows did not do the usual "found new hardware" routine, so it could very well be 2 faulty PCI slots (MoBo is the MSI RD480 Neo2, with different coloured PCI slots, for some reason ~ neither worked).

Googling came up with A.N. Other (who did not have the same issue) but complained about how long the instal took, and how it mysteriously started working after the 1st few attempts?

Wonder if any other Forumites have tried this particular PCI adapter, with or without problems?

  Danoh 12:46 20 Feb 2006

sorry Router is K5D8230-4 ~ dyslexia coming on!

  keewaa 15:32 20 Feb 2006

These light help click here=

  Danoh 09:28 21 Feb 2006

Thanks again, keewaa. Those were a great help and interesting reading. Thanks for digging them up ~ much appreciated.

The correct orientation of the card before insertion was not my issue; the card will not insert properly the wrong way, any old how?

My MoBo's PCI slots work fine; I simply did not push down hard enough ~ new PC so a bit stiff. So other PCI expansion cards work fine, just not this Cardbus adapter.

I had also tried it via Windows Zero Configuration (mentioned in one of the posts) but once the card is inserted, the PC freezes up again (clearly a device conflict).

Perhaps, as one post mentioned, its down to the BIOS not being able to support 32-bit rather then 16-bit PCI cards, which is what the Belkin's Cardbus is. Not something I'd expect as the PC-MoBo is only 1 month old. (MSI RD480 Neo2, with Athlon 64 x2 3800+). Nothing in the MoBo manual so will have to call the OEM.

  Danoh 10:53 21 Feb 2006

?? ISA is 16 bit, PCI has to be 32 bit minimum, by definition! DOH!! However, have found that my BIOS is version 2.58 whereas the current (Dec 2005) is version 3.1 (v 3.0 dated Oct 2005).

Not at all confident about BIOS flash updates!

  Danoh 14:53 23 Feb 2006

Just a note for readers of this saga;

Even when I disabled the built-in Ethernet (via Device Manager), inserting the PCMIA card into the adapter still locks the PC up, no matter which PCI slot I tried (IRQ conflict). (BIOS and PCI slot driver updates did not help either).

Which is a real disappointment as when installed without any issue on my other PC, throughput and range on pre-N is simply wonderful! Even 802.11g reception is solid from the pre-N router.

So, I can either go back to 802.11g thoughout (which is tough now I've experienced the reliability & speed) or re-plan my wired/wireless layout to hard-wire the one PC with the MSI MoBo.

Ticking this as "resolved" for now.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017