Belkin F5D7632UK4A & Torrent Speeds

  reddeviluk 18:17 22 Jun 2006

Hi Guys, I have been having a problem for several months and have yet to find a solution which is why I am finally writing this post.

I had been using a Belkin F5D7630uk4A for 2 years, loved it, a doddle to set up, did everything I wanted and would have happily never upgraded, sadly after 2 years of constant use this unit gave up the ghost and stopped working, I then applied for a new unit under the Belkin lifetime warranty, sadly this older unit was no longer produced so they sent me a F5D7632UK model (version 2000 or 3000, not sure which), this unit arrived with a damaged case so was sent back to Belkin, before sending it back I tested it and sure enough everything was fine, the replacement model was a F5D7632UK4A (Version 4000) and it’s this unit that I am having problems with. I mainly use my 2mb Pipex broadband connection for downloading torrent files (legal only), my old unit used to let me achieve speeds well into the 100’s, occasionally 200+ KB/s, my new unit seems to limit me to 20-25KB/s which is roughly what I can upload at (256KB/s upload speeds). My PC has not changed, my Belkin PCI card has not changed (F5D5000) and lastly my software has not changed, the only change being my Belkin wireless modem/router. I am still achieving almost full signal strength between my wireless modem//router and it’s still quoting 54MBPS as the connection speed. Worth noting that a speed test run on my PC does stand up to my ISP’s speed claims and I still surf at full speed, the only thing that runs slowly is Bittorrents. I have tried several bittorrent clients which all seem to achieve the same slow speeds, my ports are forwarded (have tried several) as I am quite happy with this aspect of setting up my modem/router and in fact the set up screen on my modem quotes “Data Rate Down / Up - 2272Kb/288Kb” so I know the speed is there, just sadly not with bittorrents.

I have already checked and rechecked firewalls (that have not changed since I switched units), channels, interference, in fact, nothing at all has changed apart from the Belkin unit, so I am at a loss.

My Belkin F5D7632UK4A (Version 4000) came with firmware 4.01.09 pre-installed and this is still the current firmware (according to the auto firmware upgrader as no firmware appears for this unit on the Belkin website.

As a final test I plugged my PC straight into a USB modem and removed the Belkin unit from my system and can confirm that my torrent software is fine as I started to achieve figures similar to the max speed allowed with my ISP account (200KB/s). So it’s not my PC or the torrents themselves.

Anyone know where I am going wrong or what I am missing?, my PC runs XP Pro SP2.

HELP PLEASE as it’s driving me crazy.

Thanks in advance for any help/advice offered.

Red Devil

  seanquinn 20:43 05 Oct 2006

I can't help with your Torrent speed issue but I have recently installed a similar Belkin unit for a friend (it is a uk4 NOT a uk4A and the version is 3011. However I have ugraded the firmware from the Belkin web site. The ISP is also Pipex.

Our problem was getting the modem to connect reliably to the WAN (ISP). I thought it should connect automatically on power-up (like a cheapo one that I own) but I can only get it to connect "on demand" (ticking the check box on the second page of the WAN set-up, Outlook or IE triggers a connect. This takes about 20 seconds to connect during which Internet Explorer shows "page not found". Outlook seems to get ther quicker, don't know why.

Just wondered how you connect and if you are familiar with the settings I mention. "Connect on Demand" is not checked in the default settings but it is the only way I can get it to connect. Phone calls to Belkin technical support have not clarified the issue for me.

  ade.h 20:47 05 Oct 2006

I've got a bad case of deja vu!

  reddeviluk 21:41 05 Oct 2006

Hi there, my problem has resolved itself and I am now a happy Belkin and Pipex customer (though they decided to throttle download speeds). My settings are as follows:

Internet/WAN Connection PPPOA
Username/Password - As supplied by Pipex
IP Assigned by ISP (YES)VPI/VCI (0/38)
Encapsulation (VC MUX)
Dial on Demand (TICKED)
Idle Time (minutes) - Set to 0
MTU - 1454

Hope this helps you and your friend, if you need me to run through any other settings feel free to mail me or add me to


red D

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?