Baffled by ethernet connection problem!!

  Simsy 20:26 09 Nov 2010


What can this problem be...

I recently built a new PC from scratch. After 2 months a problem appeared; I wasn't getting an internet connection... Specifically the computer wasn't detecting that an ethernet cable was plugged in. (No lights at the ethernet socket, or on the router indicating a cable plugged in). It was a bit intermittent... It would work for a while and then stop, for a long time, before working again.

I changed the cable, to one working with another PC.. That didn't work. Put the cable back to thee other PC and it works, so not a faulty cable.

I changed to using another outlet on the router... That didn't work, and the same router socket is working ok with another PC, so that would seem to rule out the router socket.

The PC in question I dual boot, using 2 hard drives, Windows 7 and Ubuntu. The same problem manifests on both Operating Systems, having worked OK on both to start. This would seem to rule out a software issue.

So it's not a faulty cable, router or software... surely it must be the network socket, i.e. the motherboard...

So I returned it under warranty. Gigabyte tested it and said no fault found, but they agreed to swap it for another one anyway...

However, this process was taking ages, and there was important work I needed to get on with, so I decided to buy another motherboard, (an ASUS), to get a working PC, and to sell the replacement Gigabyte board when it eventually reached me...

After 2 days of using the new motherboard I have come across the same problem!! Same checks, (cable OK, router OK, software OK, fresh installs), indicating the same result, motherboard ethernet socket problem!

This can't be the case can it, surely; 2 different motherboards, from 2 different manufacturers, giving the same, (rare?), fault??

The only thing I can think of is some kind of temperature problem, but I really don't believe this, because;

The case is well ventilated, with a clean layout, and fans all working, (and the right way round!)
The unit isn't being driven hard, at all, (no gaming, video, or picture editing), just simple undemanding tasks.
CPU core temps indicated at 24-30 degrees.
Mobo temperature indicated at similar figure.

Any ideas, anyone?

Thanks in advance,



  LastChip 20:43 09 Nov 2010

Can you ping the router?

  Dark Mantis 21:14 09 Nov 2010

Why have you ruled out the router? Have you tried a hard reset of it?

  User-312386 21:47 09 Nov 2010

Its not you, the problem lies within windows 7 last update! This drove me insane about 2 weeks ago after i updated windows 7 with the latest updates, the nic/ethernet port just dropped signal and the light where you plug the ethernet went out. I rolled back the updates and hey presto all was well. I then updated last week and they must have brought a patch out as all is working well now!

  Simsy 22:04 09 Nov 2010

I'd ruled out the router because the same router, using the same physical port, and the same physical cable was working OK with another PC, a laptop.

I can't "ping" because the problem is between the PC and the router... it's like there's no cable present!

Thanks madboy33©®... but I don't think it's that because the problem didn't appear after an update... it just appeared.

My first post was from the laptop... In the meantime I've turned off power, completely, to the whole kit and caboodle... Thats to say the power switch at the socket that powers all this gubbins, (after shutting down correctly).

After leaving it all aff for 30 mins or so I'v e repowered and all seems well again. This is exactly what happenned last night as well. In the meantime I've tried turning power off, completely, to the PC, and leaving it off. That didn't seem to work.

I'm wondering if it's something to do with the modem/router, (Virgin cable and DLink 615 router).

I'll happily, and desperately, consider other opinions, if there are any out there!

And just in case, madboy33©®, do you have any idea which update?




  LastChip 23:04 09 Nov 2010

Doesn't explain why it doesn't work in Ubuntu.

If you open a terminal in Ubuntu and type:

sudo ifconfig -a

(hit Enter)

Check the eth0 entry and what do you see?

Does eth0 exist, if it does, what information are you seeing?

Are there any other entries associated with that command?

  woodchip 23:21 09 Nov 2010

Have you tried flashing your router with the latest update for it?

  Simsy 07:16 11 Nov 2010

but I'm none the wiser as to where the problem might lie...

I have Virgin cable, so a separate modem and router...

A thought has occured to me... It MIGHT be happening, (the loss of connectivity), when the PC goes into standby after a period of not being used, but booted up. I'll need to check if this is so, by trial and error.. I'm clutching at straws, but could there be a setting in the BIOS I need to check? If so which?




  LastChip 12:34 11 Nov 2010

You need to systematically work through the system and find out where the blockage is. Leaping from one idea to another, will not (unless your extremely lucky) provide a solution.

The first thing you need to find out is whether your hardware is being recognised - hence my question above.

The answers I asked for, will also tell me if you're getting an IP address or not and therefore, which direction to proceed.

If you're not prepared to provide the information, how do you expect help?

  Simsy 15:34 11 Nov 2010

When the cable is recognised all works well... when it isn't recognised there is no ethernet connection at all, in UBUNTU or Windows...

I am trying to work systematically...

The cable has been changed.
The router port has been changed
the ethernet socket, (ie the motherboard!) has been changed...

At the moment is is working... I am booted into UBUNTU and having done what you've said the resulting output is as follows;


eth0 Link encap:Ethernet HWaddr 20:cf:30:38:52:0b
inet addr: Bcast: Mask:
inet6 addr: fe80::22cf:30ff:fe38:520b/64 Scope:Link
RX packets:5708 errors:0 dropped:0 overruns:0 frame:0
TX packets:5982 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4134257 (4.1 MB) TX bytes:1139663 (1.1 MB)
Interrupt:51 Base address:0x8000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:24 errors:0 dropped:0 overruns:0 frame:0
TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1440 (1.4 KB) TX bytes:1440 (1.4 KB)


Bearing in mind it is currently working I'm guessing that doesn't provide much?

In my previous post I was indicating that I'm guessing what event causes it to stop working. I have to clutch at straws at the moment!

When it next isn't working I'll try the above again and post back.

(Just to be clear, when the problem is present I can't even see the router... it's as if there is no cable present... I don't get a light either on the router, on by the ethernet socket on the PC)

Thanks for your help,



  LastChip 16:12 11 Nov 2010

If (or when) it fails again, please do the same thing.

I the meantime, can you run:

netstat -nr

That will confirm the (internal) gateway address you're using and would potentially be useful when troubleshooting the next stage.

Finally, can you please confirm the router is a DHCP server and providing dynamic addresses to your computers.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?