ATI drivers won't load

  [email protected] 20:41 01 Nov 2007
Locked

I have a Mesh Matrix destop with an Athlon 64 3000 cpu, running XP Home + SP2. The original Radeon 9550 (AGP) graphics card was starting to struggle with some of the newer games, like Silent Hunter II, so I thought I would update the drivers as a starting point. I followed the ATI website advice, uninstalling/removing everything that has ATI in it's name. I then tried to install the latest drivers (Catalyst 7.10). Everything went fine until the last moment, when I get an error mesage saying "Severe-Setup did not find a driver compatible with your current h'ware or operating system". I tried a number of previous driver versions, but without success. Thinking it may have been the card, and wanting something better anyway, I bought a new Sapphire X1650 Pro. Installed card no problem, but I get the same error message when installing the drivers. Uninstalled everything again, and used 'DriveCleaner.net' to sort out any old driver issues, but same problem. Don't know if it's linked, but System Restore now won't work. Any ideas?

  I am Spartacus 21:15 01 Nov 2007

No ideas but I do recommend the Omega ATI drivers click here if they will install instead.

If they do install then go to display properties and advanced settings, 3D and change the option to performance for Direct3D and Open GL rather than quality if you want a big boost in performance.

  exodus 00:19 02 Nov 2007

Hi, it is normally a painless procedure so I am not sure what has gone wrong.
Download the latest drivers again just in case you had a corrupt download first time.
click here

Ensure you select the correct operating system/ card/ model.

Open Control Panel/Add Remove Programs. Depending on what you previously installed, you may have in the list something like ATI removal software. Highlight and select remove and this should remove all your ATI software. If this tool is not present, just select the ATI programs shown and remove each in turn.

Check your C drive and manually remove/delete the remaining ATI folder.

Reboot the computer. Windows will alert you to found new hardware. Cancel all Windows attempts to install the hardware or its drivers.

Locate your ATI downloaded catalyst/drivers folder and open to install.

When done, reboot when prompted.
check device manager or display Properties to ensure correct display adapter is shown as in use.

Let us know how that goes.

exo

  [email protected] 21:49 02 Nov 2007

Spartacus,
Tried the Omega drivers. The installation actually completed (unlike the Catalyst), however the drivers didn't actually install. In the Device manager, it said drivers were not installed, so I manually directed the hardware wizard to look in the newly created 'Omega' folder. although it found them, it finished with "an error has occurred during the installation of this device. Access denied".

Exodus,
Removed all the old ATI files again, downloaded the latest drivers again (7.10), and then tried to install. No luck. Tried to manually install by directing the wizard to look in the exact folder, but still no good.

I'm beginning to thinks I've either mistakenly removed something important that I shouldn't have, or I have a more serious hardware issue, as the same problems arise whether I use my original Radeon 9550 card or the newer Radeon X1950 Pro card.

  citadel 22:13 02 Nov 2007

will the driver that came on the disc with the new card not install.

  exodus 23:49 02 Nov 2007

Hi, could be hardware related.

You do have the Microsoft .NET Framework versions 1 and 2 installed?

exo

  Stuartli 00:11 03 Nov 2007

I also have a 9550 graphics card. I always download the latest driver version for the card from the AMD website but, instead of the Catalyst software, use ATi Tray Tools.

These are not only a fraction of the download size of the Catalyst drivers, but provide very similar features. See:

click here

  [email protected] 18:31 03 Nov 2007

Citadel,
The drivers that came with the card are 'old' Catalyst drivers (Ver 6.8). Same problem as above though.

Exodus,
Yes I have Microsoft.Net Frameworks Ver2.0, and 3.0 installed.

Stuartli,
Thanks for the tip, but unfortunately no success.

Appreciate the help everyone.

  citadel 19:17 03 Nov 2007

try checking for motherboard driver updates as these affect graphics cards.

  exodus 20:00 03 Nov 2007

Hi, ummmm, somewhat frustrating. As a long shot, try the normal ATI removal.
Reboot and ignore/cancel Windows attempt to install found hardware. Run a registry cleaner such as Eusing (free download). Install new drivers.

If the problem still persists, repeat the above procedure but install new drivers from safe mode.

exo

  [email protected] 19:00 07 Nov 2007

Hi Citadel,
Downloaded latest drivers for the ASUStek K8V-MX motherboard, then tried everything again. Same result.

exodus,
Tried what you said, only used the Ashampoo WinOptimiser Platinmum 3 registry cleaner that I have installed. Unfortunately, still no joy.

Beginning tio think I may need to leave it in somewhere for someone more qualified than me to fix.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Aardman's new YouTube channel to share the work of independent animators

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017