Asus A7N8X Fails to recognise CD drive

  Wilkoandout 10:52 07 Feb 2003
Locked

I have installed an A7N8X Deluxe, adjusted the BIOS to set CD-DVD drive and CD-RW as master and slave respectively in the Secondary IDE slot. However when initial boot is commenced and New Hardware Wizard kicks in the Win98 disc was requested in CD-DVD (D drive), but only A & C drive were available. I feel it may be a problem related to the Secondary IDE set up, but have been unable to resolve. I note an IDE jumper is referred to in the quick set up guide but is not mentioned in the main A7N8X installation manual.
Without D I have no way of installing Nforce2 driver. HELP any ideas!!

  Poloman69 23:19 07 Feb 2003

I have had the same problem.

One trick i learnt is that not to have two CD Drives on the one ribbon. When i put one CD Drive & One hard drive on one IDE Cable, and the other one with my second hard drive on the other.

Then i ensured that the Master & Slave tabs on the back of the CD Drives were placed correct.

Finally going into BIOS i selected it to automatically detect all the drives for me - saved this and restarted.

Too, did i get the new hardware wizard, ensure the drivers i was installing were relative to my CD drives.

One final restart and volia

  DieSse 23:32 07 Feb 2003

Ideally the CD-RW should be master, and the DVD slave.

Try just one drive at a time - one faulty drive can make both unrecognisable. Also check very carefully that the IDE cable is the correct way round (red stripe edge goes to pin1 - on the drive end that is always on the side the power connector is on).

  DieSse 23:35 07 Feb 2003

Just notced one thing you said -"in the BIOS set ....". Don't quite understand that - you don't normally make such settings in the BIOS - it's governed by the jumpers on the rear of the drives.

In the BIOS, you would normally set all drives to the Auto setting, and let the POST discover what they are.

  Poloman69 23:43 07 Feb 2003

I personally found that by automatically selecting it in Bios rather than just selecting auto worked better for me.

When i had the problem, selecting 'auto' for some reason when i looked on 'my computer' it was showing i had 3 Hard drives (C,D & G) present instead of the two i have.

  clayton 02:04 08 Feb 2003

I would go back into the bios & set it to default until you have setup your pc, the jumpers referred to in the quick set up guide are on the hard drives, just read the user manual & make sure the secondary ide cables are connected the right way round.

  oneMegaBit 02:10 08 Feb 2003

check that the jumpers on the drives aren't set to cs (cable select) although a good idea in principle it dosen't always work in reality (it allows the master/slave to be configured in the bios) much better to set them yourself as master/slave.

  DieSse 16:14 08 Feb 2003

Just for information - the Cable Select jumpers do not allow you to configure in the BIOS. The choice of which is Master and which is Slave is made by where they are on the cable - The last drive will be Master and the one on the middle connector will be Slave - this is why 80wire cables (the ones which allow cable select) are usually marked so.

I agree that it's often better to specifically make the jumper settings master and Slave.

  Wilkoandout 19:26 09 Feb 2003

Thanks for all your info. checked it all through and found a trail to the solution.

I set the Access codes in the BIOS to something called CHS and all went relatively well, at least the drives worked. Found a few more hitches, but at least I have a working system again!!

The struggle continues, I can see at least one more call for help coming up!!

  DieSse 01:06 10 Feb 2003

Setting the Hard drives to CHS is definately incorrect, and will affect their performance, and possibly give other problems too.

One point that occurs to me - on some motherboards, it's better to set the BIOS for optical drives to None. Don't worry - they may still get detected. Worth a try anyway.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

HP’s new Surface Pro rival is designed specifically for Adobe-using designers and artists

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?