Ashampoo Winoptimiser 2008 - uninstall

  PA28 18:23 08 Feb 2009

Help. I installed this from the PCA disk some time ago and now I want to uninstall it. The process fails every time as the uninstall can't find the file "install.log". I've tried reinstalling and uninstalling, but the file dopesn't seem to be recreated (assuming it was there in the first place). I've tried unisntalling using CC and Revo uninstaller, and they fail to complete for the same reason. I just want rid of this program - any ideas please?

  brundle 18:34 08 Feb 2009

Often happens due to a badly written uninstaller. Install the program. Does it have an actual Uninstall/Remove shortcut, or is there only an entry in Add/Remove Programs (assuming XP) ?
Useful to know, the it's easier to explain removal if it has a shortcut.

  PA28 19:34 08 Feb 2009

Reinstalled again and checked files. There is an uninstall facility, the shortcut leads to .... Winoptimizer2008\uninstall\1806_Uninstall.exe. Running that again results in the error message (in a box labelled Wise uninstall) the the file UNINSTALL.LOG cannot be found. There is no such file on my machine! IN the same folder lurks a file named 1806_INSTALL.LOG. This cannot be "saved as" in the same folder, but it can be renamed. I renamed it to INSTALL.LOG which changed both the properties and the size! Running the uninstall routine resulted in the error message Cannot open INSTALL.LOG - and then the file 1806_UNINSTALL.EXE vanished from the \Uninstall folder!!

I am tempted to do the unthinkable and manually delate the whole of the Ashampoo Winoptimizer2008 folder and associated shortcuts, and then get a registry cleaner to clear up the hidden bits. Any views?

  PA28 19:36 08 Feb 2009

Vista Home Premium by the way ..... should have mentioned that earlier.

  brundle 20:17 08 Feb 2009

OK, if you've got as far as that folder it's easier to explain. Right click the Uninstall shortcut and select Properties, the Target box will be highlighted. Move the cursor to the far end of the field, add a space and the uninstall log name eg;

"C:\Program Files\Ashampoo\Ashampoo WinOptimizer 2008\uninstall\1806_Uninstall.exe" 1806_INSTALL.LOG

Click apply and accept the `You will need admin permissions` box, then double click the newly saved shortcut which ought to remove the product with no errors.

  brundle 20:18 08 Feb 2009

Apologies, it doesn't fit all in one line in a post, but it will do in the actual dialogue box.

...1806_Uninstall.exe" 1806_INSTALL.LOG

  PA28 20:32 08 Feb 2009

I see your logic - hadn't thought of coming in from the shortcut end. Neither inmfortunately had Ashampoo as it returned the same error message even after the shortcut had been modified. Obviously there's something in the uninstall .exe file that looks for Install.log - and it isn't going to be swayed.

Thanks for your idea - I thought it was a good one. Any other thoughts please?

  brundle 20:40 08 Feb 2009

Do the same but run it from a command prompt. You'll need to select Run as Administrator (right click the shortcut), type or cut/paste

cd C:\Program Files\Ashampoo\Ashampoo WinOptimizer 2008\uninstall

into the command line

then use the command

1806_uninstall.exe 1806.uninstall.log

I know it's basically the same thing, but this kind of error occurs with WISE installer products and the solution above works for those...

Worked for me using an XP virtual machine too...

  brundle 20:41 08 Feb 2009

One more thing to try, make a copy of the 1806_install.log file and rename it install.log. Try removal with or without the new filename tagged on at the end.

  brundle 20:48 08 Feb 2009

OK, now the VM is doing the same thing. Don't click 1806_Uninstall.exe to remove, click Unwise.exe; it will complain about the log file and then open a file requester. Locate the copy of 1806_install.log named simply install.log, click OK.

  PA28 22:19 08 Feb 2009

Tried the command prompt window - no dice. Same error message.

Then tried the renaming and running Unwise.exe (that file name worried me). Success!!! Uninstall ran and although it left a few remnants (which I cleared manually) the thing's actually gone!

Thanks for your help and patience brundle - much appreciated and a few tips filed in the back of my mind for the future. Cheers!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

Camera tips to take better iPhone photos

Comment transformer un iPhone en borne Wi-Fi ?