Any registry Experts?

  MIke 06:47 04 Dec 2009

Morning all

I use Allway sync on my laptop and desktop PCs both running Win 7 Home Premium. You can set the program to autostart at log on. This works fine on my laptop but not my desktop.I contacted Allway sync support and basically the program should write a value to a registry key which it's not doing. details :-

Please make sure you have permissions to write to the system registry. If you don't the synchronizer will not be able to create registry key for automatic start. Also you can check manually that the registry key was created:
1. Click Start --> Run or use Win+R shortcut.
2. Type "regedit" command. Click "OK" button.
2. In registry editor navigate to "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run" branch.
3. Make sure that the "Allway Sync" key exists and has value like "C:\Program Files\Allway Sync\Bin\syncappw.exe" -m.

If "Allway Sync" key does not exist you can try to create it manually. It should has "REG_SZ" data type and value like "C:\Program Files\Allway Sync\Bin\syncappw.exe" -m

I have all the appropriate permissions set to write to the run key mentioned but cannot create the string value either through the program or manually. more to follow

  MIke 06:50 04 Dec 2009

Please try the following solution:
1. Run Registry Editor.
2. Navigate to "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run" branch.
3. Right click "Run" key, and select "Permissions".
4. Click on the "Advanced" button.
5. In “Advanced Security Settings” dialog window, go to the "Owner" tab.
6. Select and highlight the currently logged on user name or Administrators group (if user is a member of "Administrators” in the "Change owner to:" box).
7. Select the tick the check box for "Replace owner on subcontainers and objects option", and click OK.
8. Back in “Permissions” dialog window, click on "Add"… button.
9. Enter the user’s login user name in the "Enter the object names to select" text box, and click OK.
10. Back in “Permissions” dialog window, select and highlight the newly added user name in "Group or user names:" section, and tick the checkbox for "Allow" access right next to "Full Control" in the "Permissions" for <user name> section.
11. Click on OK when done.

Then try to enable auto start option in Allway Sync or create "Allway Sync" key manually.

Did all of above still no joy.

Have run sfc /scannow no issues found
Have installed Allway sync as administrator still no luck

The only thng I can think of now is to re-install windows or just carry on running prog manually.

The concern I have is that if registry is the problem will other programs start behaving badly?


  MIke 08:28 04 Dec 2009

It was Nat West's security program Rapport.
Apparently it locks the registry key in question.
Found this via MS Help and Support

Fix for Rapport:

> The problem you have reported may be related to one of Rapport's protection mechanisms.
> We'd like to ask you to disable Rapport's protection from Unauthorized Removal and let us know if the problem is resolved.
> Instructions for disabling Rapport's protection mechanism against Unauthorized Removal:
> 1) Open Rapport's Console (Start > Programs > Trusteer Rapport > Rapport Console)
> 2) Click on the "Right Arrow" Icon
> 3) Click on "Edit Policy" in the "Security Policy" widget
> 4) Type the required characters
> 5) Locate "Protect Rapport from Unauthorized Removal" and choose "Never" in the Drop-down list
> 6) Click on Save
> 7) Restart your PC and see if the problem still occurs

The above fix now allows Allway Sync to write the required value to registry


  Terry Brown 08:58 04 Dec 2009

As it was a secuity check, added by your bank (Nat West)and you have removed it, your banking details may not be safe!!.

Be vey careful when removing 'safety ' checks.

  MIke 21:38 04 Dec 2009

I haven't actually removed Rapport, it's still running. Apparently it protects itself from being uninstalled by locking that registry key.
However legitimate programs need to write to that run key, my lightscribe software (installed before Rapport) has a value there, presumably if I'd installed Lightscribe after Rapport I'd have been troubleshootinng issues with that too.
The solution I found on the net came from someone who had trouble setting up some mouse software which couldn't write to that key.

I think Trusteer who publish Rapport should at least warn users they may have issues with other software because of their protection policy.

I've spent about 3 weeks troubleshooting this!!

  Trusteer Support 07:00 15 Dec 2009

Dear Forum users,

You are correct. This is a known bug and it has been fixed in our latest version, which should be available this week in fact!

We strongly recommend anyone suffering from this problem to follow the above steps (it is actually a quote of our official response to the problem) and re-install Rapport, from the original location where you've previously installed it, towards the end of the week.

Once you have, open the Rapport console, make sure it is version 911 and if it is - access the "edit policy" section again and click "restore defaults" and "save".

This way you will once again be fully protected without the problem above.

We would also like to recommend you contact us for any problems or questions:
[email protected]

Trusteer Technical Support Team

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017