Alcatel speedtouch USB woes above 2.3Mbps.

  Dorsai 20:12 19 Dec 2007
Locked

HI all.

I have an Alcatel Speedtouch USB BB modem.

I have tried and failed to find out it's abilities. I would like to know, has anyone got one that is working above 2.3Mbps?

I have recently upgraded my BB connection, and I should be able to get "6Mbps" That's what my line can do, I am told. My ISP say that's what they are giving me.

I am stuck on 2.3Mbps.

I don't know if this limit is because my modem can't go above 2.3, USb cant do it,, or because I am not getting what I pay for....

Speed tests are consistent with the 2.3 the modem reports it is giving.

  skidzy 20:20 19 Dec 2007

Is this the Speedtouch 330 ?

If so,it should handle upto 4Mb though you can try the high speed driver.

Though depending on how busy the line/exchange is will determine your speeds.

Highspeed driver for the ST 330 click here
needs a few changes.

  Dipso 20:33 19 Dec 2007

Follow this click here and find out what your receive attenuation is. Post back with the figure and I'll tell you what speed you should expect.

  skidzy 20:37 19 Dec 2007

Hiya Dipso
Handy link you have there,cheers for that. (bookmarked)

Thanks again.

  TonyV 20:46 19 Dec 2007

I have the Thompson 330, at least one of the earlier ones, about two years old. I used to get 6.4 to 7.2 Mbps, 15 months ago, but when I moved to Somerset, BT insisted on a new contract and my speed went gradually down hill. It varies quite a lot but now I usually connect between 4.8 and 6.2 Mbps. That's what is showing on the task bar icon. I tried the speedup driver but it made no difference so reverted back to the original one.

TonyV

  Stuartli 22:07 19 Dec 2007

The Speedtouch 330 will handle "up to 8MB" by downloading the latest driver or the "up to 8MB" patch. See:

click here

  Stuartli 22:15 19 Dec 2007

Also:

click here

The Speedtouch is initially intended for up to 4MB - there's another link lower down this link for the new drivers:

click here

  Dorsai 20:08 20 Dec 2007

I will try and reply to all posts.

It is a Speed touch USB. click here

The stats I finally found click here

which state is can do up to 8Mbps.

Currently trying Dipso's link.

Have already installed the Drivers recommended by Stuartli's firs link.

Have downloaded the drivers from Stuartli's second link. Will try them aslo.

TY all for help. Will report back.

  Dorsai 20:31 20 Dec 2007

DrSpeedtouch wont work.

Followed the trouble shooting guide.

All setting are as it wants. Apparently, I don't have an Internet connection. ROFL!

  TonyV 22:07 20 Dec 2007

I tried the first link on Stuartli's message 19/12/07 22:15 to optimise my 330 on the off chance it may have brought it back up to what it was on when first installed. In fact it slowed it down and I then reverted back to the old settings and it went back up to what it had been running at recently!

Cheers

TonyV

  handy4x 22:22 20 Dec 2007

try this new firmware click here mine is realy old type [purple frog style ] and now conects at 5.5 or 4 when it is at peak times

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

HP’s new Surface Pro rival is designed specifically for Adobe-using designers and artists

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?