Alcatel SpeedTouch USB Modem

  Colin 13:02 26 Apr 2004

I received the above modem as part of my BTOpenworld Broadband package in August 2002.
It has worked perfectly until last Friday night when it refused to display two solid green lights. It only had the left side (USB) light flashing which then turned into a steady flashing red light. A few seconds after this I get a blue screen on the PC and then the PC reboots. I am using XP Home with SP1. I have unoinstalled the modem, used the latest drivers as well as trying the other USB ports. I even formatted ny hard drive, but got exactly the same problem. On Saturday morning I bought a ZOOM USB ADSL modem from PC World, installed it and it works perfectly. Two questions: does anyone have any idea of what the fault with the Alcatel modem is and is there a warranty on it? Now that I am back online, I have searched the BTOpenworld site, (T Yahoo Broadband,actually) but with no success.

  anchor 13:26 26 Apr 2004

The fact that the Zoom modem works fine seems to rule out problems with your broadband connection. In view that it worked previously, and you have done all that you described, it does suggest a modem problem.

To determine if your Alcatel modem has an extended warranty, you would have to ask BT. However, I suspect that it was probably only for 12 months.

  Colin 13:40 26 Apr 2004

I suspected as much. I have searched the PCA archives and others for similar problems, but couldn't find any. The ZOOM modem was £40, so I'm not too concerned. I

  spuds 23:54 26 Apr 2004

I find that the SpeedTouch support click here are okay.I had a similar problem with the SpeedTouch 330, and the result was a faulty chipset on my motherboard, which was a known problem to Thomson's [Alcatel is their previous name].

  Colin 12:44 27 Apr 2004

Thanks, Spuds. I will e-mail them tonight. If I get anywhere I will at least have a spare modem for the future.

  anchor 13:41 27 Apr 2004

I well recall past reports in this forum about a chipset, (I think it was the Via), having problems with the Alcatel Speedtouch.

However, as your modem worked fine for about 20 months, I really cannot imagine the chipset is the cause of your problem.

I assume that you have not changed the motherboard.

  Colin 19:58 27 Apr 2004

Anchor, you are right, the PC is the same as it was when I got broadband. I am sure it is the modem. I have e-mailed Alcatel. Will report back with their response.

  Colin 16:24 01 May 2004

I received a pretty standard reply from Thomson saying to update the USB drivers if I have a VIA, ALi or SiS chipset. Strange, as it asks on the enquiry form what chipset you have, (mine is an Intel 845). It also suggests testing the modem on another PC. I'll do this next week.

  spuds 19:41 01 May 2004

My problem was traced back to a chipset problem. Never bothered to correct this,as the drop-out is only a minor hindrance. This problem will be corrected shortly, when I have a mobo change, which is long overdue.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Android Oreo News: Release Date & New Features

Best Photo Editing Software for iPad

iMac 21.5-inch (2017) review

Comparatif : quelle est la meilleure batterie externe 2017 ?