Agfa Snapscan 1212U

  Blake 20:44 27 Oct 2005

I've seen the posting about the Snapscan P, wondered if anybody has got he USB version to work in XP? Worked ok im win 98 and win 2Kpro.

I tried the driver for XP from the Agfa site, and just get "Communication error" when trying to launch the software.
Any ideas or is it get out the wallet time?


  Blake 17:42 28 Oct 2005

.....any advice for a replacement scanner should it be required?

  Stuartli 17:58 28 Oct 2005

I have an Agfa SnapScan 1212u - it started off with Windows 98, then 98SE and now runs very happily with XP Pro using the XP ScanWise 2.0 software and drivers.

You'll find it at:

click here

  terendak_uk 18:02 28 Oct 2005

Had one a couple of years back. Upgraded the attached PC OS to XP.Also used the AGFA drivers with same result.Eventually found a driver from, I think, BUT, it only worked intermittently, so....I dumped it.

  Stuartli 19:34 28 Oct 2005

Make sure you uninstall the earlier Scanwise version first and that the scanner is disconnected during the installation.

As I stated earlier, my 1212u works exactly the same as with earlier versions of Windows.

You can probably guess how long I've had it because it cost me just £32.33 including delivery on special offer from; I snapped it up because it was being advertised elsewhere at up to £104 and on's own dedicated Agfa products section for £75...:-)

  Blake 18:17 29 Oct 2005

Thanks Stuartli

I've tried that driver, after uninstalling the earlier Scanwise version, and reinstalling with the scanner disconnected but still get the same result, several times.
I'm using XPHome, surely that could not make a difference?
I'll trying it again and see what happens.

  Stuartli 18:43 29 Oct 2005

I use XP Pro, but the difference using ScanWise with Home should be nil.

Alsory a different USB port. You do have the power adapter connected as well?

May sound simple or even stupid, but it has been known...:-)

Here's other ScanWise links:

click here

click here

Not sure if these are the same as the Agfa website version.

  Stuartli 18:44 29 Oct 2005

That should read ..also try a different USN port...

  Stuartli 18:44 29 Oct 2005

It gets worse...

...also try a different USB port...

  woodchip 18:50 29 Oct 2005

You need to unload All Software and Drivers for tha Agfa, then Restart the computer with the scanner disconnected, then load New Drivers and Plug the scanner in it should then work

  Stuartli 21:07 29 Oct 2005

Blake has stated he has already been through this routine several times.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?