after defrag ext hard drive stopped working

  gerryp25 13:05 12 Jan 2008

Hi, I have a Pika One Flycase 320 Gb external hard drive which has been working perfectly for about 2 years which now no longer works after running the de-frag on C drive. The message I get when trying to back up is 'no external drive has been detected'. The drive is powered up and showing a steady green light sometimes flashing orange which it does when accessing the disc, in the split second when the orange light appears I see 'Initialising disc. but then the the 'no drive message appears'
I have uninstalled and re installed the drive from the supplied disc which says everything has been succesfull, tried different sockets for the USB2 and power leads.
Tried updating drivers but the Wizard says no better drivers are available.
When double clicking the disc drives in device manager it says device is working properly.
At the moment the drive is showing the green light with the split second showing of the orange, this is accompanied by a click and a slight tremor when feeling it.
I thought I would try an earlier restore point to see if that would help but found that they had all disappeared, is this due to the de-frag?.
One other thing, the last time I did actually get it to work for few minutes, on the ' My Computer ' page it said the ext. drive wasn't formatted, this after using it for 2 years.
The reason I used the de-frag was to tidy up things I wasn't having trouble but just thought it was supposed to be part of a regular routine, wished I hadn't bothered.
Does the flashing lights and click on the drive mean the ext, hard drive has had it?

  Technotiger 13:19 12 Jan 2008

Doing a defrag should not affect your System Restore points.

Try scannow ...

click here

  gerryp25 21:57 13 Jan 2008

Thanks Technotiger, I am not up to speed with computers and your programme appears to be a bit complicated.
I just wondered if the ext. disc was broken with the flashing, clicking and the slight tremor when touching the case.

  Technotiger 22:03 13 Jan 2008

Hmm, OK, it does seem a possibility that your drive has expired, passed away, given up the ghost, or simply died! Clicking and trembling should only happen when She is nearly ready - but in this case is not a good omen!

If you can smile when in adversity, you are a Man my son!

  UncleP 01:28 14 Jan 2008

The chance that a de-frag would cause your HD to fail are small; more likely that it has corrupted some part of the stored data. And the flashing, clicking etc do not, as you describe them, sound like a typical failing HD. The 'not formatted' message is just an indication that the OS can't make sense of the signals it's getting, not that it has determined that the HD has indeed not been formatted.

Have you checked the disk management page to see what (if any) information is available there? If you can find an entry which corresponds to your external HD type and size in the list on the bottom right, there should be enough diagnostic information there to give some idea of the nature of the problem. So don't give up hope yet!

And avoid trying to write to the HD if there is data on there you wish to preserve (see the article on data recovery in the current edition of PCA).

  UncleP 01:44 14 Jan 2008

Sorry, in case you need explicit directions to the disk management page, click consecutively on the 'Start' button, then 'Administrative Tools', Computer Management', then 'Disk Management', each of which opens a new window with the next selection in the list of available options.

The list on the bottom right starts with Disk0 (the system disk C:), then Disk1 through all of your HDs, CD/DVD reader/writers etc.

If you find an entry for the ext.HD, post all of its contents here.

  UncleP 01:48 14 Jan 2008

Oh my gawd! I'm falling asleep and should be in bed - sorry, missed out 'Control Panel' after the Start button.

  gerryp25 22:11 14 Jan 2008

Thanks UncleP, followed your suggestions and found that the ext hdd appears as
CD-Rom O (D)
Don't know why it appears as CD!!!
In the table at top of page it says
Silver (D) Partition basic CDFS Healthy 276 MB
then free space 0%
Fault tolerance No
Overhead 0%
Does this help??

  UncleP 20:59 15 Jan 2008

Possibly. My immediate reaction is that this may be a result of a Microsoft flaw which, under certain circumstances, mixes up the drive letters associated with different storage devices. Which could explain why it thinks your Ext HD is actually a CD-ROM drive.

First, what makes you think that the entry you quote refers to the ExtHD? Also, do you recall the original drive letters for the HDs and optical drives in your computer? If so, when you check through them now, in Disk Management or MyComputer, have any of them changed? Secondly, disconnect the ExtHD and check whether any of the entries in the Disk Management lists have disappeared or changed. It may be that that entry will simply disappear and nothing else changes, which won't tell us much, but it's worth a try.

If this guess is correct, then it may be possible to re-assign the drive letters, which forces the system to re-determine the device characteristics and hence reset them. However, an alternative explanation could be that your problem is a result of an error in the USB system, which equally can be corrected by re-setting that.

Again, suggest that you do the checks suggested and post the results before attempting any re-setting, but it's your machine and you may keen to get this sorted out.

  UncleP 22:00 15 Jan 2008

I should have been more explicit: the Disk Management entry you gave describes a DVD-CD drive with a drive letter D: containing a closed CD entitled 'Silver' with 276 Mb of program files on it, and apparently working correctly. If this is the case, and there is no other candidate, it means that the OS is not recognising the ExtHD - although from your initial post it appears to be making attempts to do so.

  gerryp25 22:08 15 Jan 2008

Hi UncleP, thanks for the help. Usually when the ext hdd was working it showed up at the side of C drive in ' My Computer ' as K drive.
When I said last night it was showing up as Cd, I think it was picking up the fact that the installation disc for the ext was in the cd drive. Just followed your previous instructions and the only thing being picked up is the C drive. I am using a USB 2 hub but have tried different positions and also the original USB 1.1 with no luck.
One thing I forgot to mention, just before the problem started a Windows update was carried out automatically, I did the de-frag after this.
Hope this narrows it down a little more.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?