Adverts in Software (Issue 441 Workshops)

  Nelson1964 08:36 27 Feb 2015

I have just worked through the Workshops feature on editing the C:/Windows/System32/drivers/etc Hosts file to stop adverts appearing in my software. All was going well until I discovered that I don't have permission to save a file in that location.

I am running Windows 8.1 on a brand new laptop and I am the only user.

Have I missed something obvious?

  Fruit Bat /\0/\ 11:50 27 Feb 2015

Activate and use the hidden Administrator account to carry out what you need to do

Start Menu > Programs> Windows System> right click Command Prompt > select Run as Aministartor.


net user administrator /active:yes

reboot and the Adminstartor account will be shown

boot into that and do what you require to windows.

on completion to deactivate the account

go to command prompt again and type

net user administrator /active:no

reboot and the Administrator account will not be shown.

  robin_x 12:08 27 Feb 2015

Running Notepad as Admin allows saves there.

You could Start/Search notepad.exe, right click and Run as Admin then File/Open your file. Then Sace As to ...\etc (for HOSTS, type is All files and no extension)

Or create a shortcut to Notepad.exe on your desktop. Change Properties/Shortcut/Advanced to Run as Admin.

Drag and drop your your file onto the icon.

Edit then Save As etc.

  robin_x 12:14 27 Feb 2015

Works for my User account which has Admin privileges.

Not sure what you get if you have a Standard Account. (It may refuse or ask for admin password)

  Nelson1964 16:56 27 Feb 2015

Thanks for those tips, but nothing has worked. I don't have Programs on my start button, all I get are the kindergarten-style tiles and none of them is programs. If I right-click on Start then I get an option for "Command Prompt (Admin)", which looked promising. It gave me a command prompt, but when I then typed in the command line that you suggested it made no difference (after rebooting etc)

Also, any attempt to change the permissions for the Hosts file, or a shortcut, as suggested by Robintheumpteenth were all disabled, however deep I went into the advanced settings.

Any more suggestions?

  robin_x 22:04 27 Feb 2015

If you left click on Start, there is a down-arrow at bottom left of screen to take you to Apps.

If you then scroll right you get to Winows accessories and Notepad.

Can you right click that and Run as Admin?

Then you can save contents in drivers\etc.


If that doesn't work, are you sure you have Admin account privileges?

see Control Panel > Accounts

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?