address bar addresses

  scatode 21:08 25 Jun 2008
Locked

Does anyone know why everytime I log in to my laptop the address bar is blank i.e. all the addresses I have had typed in on previous occassions are not these anymore. How can I keep the addresses in the bar when I restart the laptop?

  skidzy 21:30 25 Jun 2008

Possibly;

If your using IE7 goto tools/internet options/General/browsing history/settings

Now check if you have the history days set to 0,if so change this to lets say 20.

Do you have ccleaner installed,if so this has a similar option as does Firefox browser.

  scatode 21:33 25 Jun 2008

the history is set to 999 and I havent got firefox or ccleaner installed.

  lotvic 23:13 25 Jun 2008

I thought I would check my settings to help you But I find that I have the same problem

Internet Explorer 7 is not saving URL's in Address Bar history drop down

I have just tried IE and found that mine isn't saving any at all - even within the session.
I can still use the Back / Forward a page arrows and the urls are listed in that dropdown but the address bar drop down is blank.

(I usually use Firefox so didn't notice the prob in IE till I just tried it)

My history is set to 20 days

Am off to google the problem and see what I can find out.

  lotvic 00:18 26 Jun 2008

This is as far as I have got.

My Start > Run box is empty as well.
But my Start > My Recent Documents is okay and has a list of 15 items in it.
I have been to:
1. Click on Start, then Run.
2. Type regedit in the box provided.
3. In Regedit navigate to HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Typed URLs

and mine says: (value not set)
But there ought to be a list of urls in there so something has altered it.

===========================
I found click here
""I was hacking around the registry and found a way to keeping the Internet Explorer's URL address bar drop down list permanently empty (instead of having to manually remove them by Tools/Internet Options or by cleaning out HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Typed URLs)

Here's what you to permanently disable the IE address bar drop down list:

1. In Registry, navigate to the following key:

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Typed URLs

2. Right click on the "Typed URLs" key (or folder as presented in the tree.)
3. Click "Permissions..."
4. Click Administrator (for global setting) or user you are logged in as.
5. Click Deny check boxes for Full Control and Read.
6. Click "OK"

Now, when you open a browser and surf, the IE address bar drop down list will always be empty.""
=======================
so I had a looksee and the 'Allow' boxes are ticked but greyed out
Now I'm stumped as to what to do next.

  lotvic 00:44 26 Jun 2008

I think I've got it sussed click here

""Typed Urls
Typed Urls appear when you click the down arrow at the right (or left, depending on locale) end of the address bar's edit box. The keyboard shortcut is F4. These items all have an icon to the left. This is a list of the last 25 (or so) urls you have actually typed into the address bar. Only items that you physically type into the address bar are listed here. The list is stored in a registry key. The key is HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\TypedURLs. Each value in the Key is an URL. If you click the Clear History button in the Internet Control Panel (Tools->Options) this entire key is deleted.""

So in IE I typed a url into the address bar (and went to the webpage) and then I pasted another one and now they are both in the drop down address bar history.
I closed IE and then reopened it and they were still there in the drop down

Now when I go to the registry key the value for my Default page is still (value not set) I presume because I have my home page set to a blank page.
then I have a list
url1 and the http address of a website
url2 and the http address of a website

So the answer is:
Only items that you physically type or paste into the address bar are listed

Hope it works for you as it cleared the mystery for me and I learnt a lot along the way :)

  scatode 17:51 27 Jun 2008

still does not work for me when I type or copy/paste in to address bar

  lotvic 23:42 27 Jun 2008

Have you looked in your registry?
What settings have you got? (compare with the info I found out as in my previous posts)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?