Added 2nd HDD. Primary HDD not recognised

  krypt1c 18:53 18 Aug 2003
Locked

I'v added a 2nd HDD as slave, but when I tried to boot up the master wasn't recognised. Tried replacing the ribbon in case it was faulty to no avail. Removed ribbon from 2nd HDD and all ok. Any suggestions on what the problem might be.

  seedie 18:59 18 Aug 2003

Check the jumpers on the drives.

Make sure the 1st drive is master with slave present. 2nd drive is slave.

Check BIOS for drives:put both on auto to start with, then post back

  -pops- 19:02 18 Aug 2003

Put the master drive (the "C" drive) on the end of the EIDE cable and the slave on the middle connector. Even if you use CS jumper settings the arrangement should be as that - "C" drive on the end.

  krypt1c 19:12 18 Aug 2003

seedie - jumpers are correct.
pops - 2nd HDD was connected per your arrangement.

When I had the 2nd HDD connected, then booted up I got trying to auto detect Master, then trying to auto detect Slave. I then got a message along the lines trying other drives for boot sector. Not found insert bootable floppy disc.
But as soon as I removed the middle connector from the 2nd HDD pc booted up fine.

  krypt1c 22:15 18 Aug 2003

^ ;-)

  TBH1 22:31 18 Aug 2003

krypt1c - -just a thought mate - - -your primary hard disc may have been set to "single" as opposed to "master" - -double check that it is now set to master and your secondary is set to slave.
Whatr does BIOS say ? And if you boot up from floppy and fdisk, what does it say ? Does fdisk see both your drives ? And if I don't reply to your reply, I've nobbed off to bed - - well, once James Bond has finished ( sad I know !!!)

  krypt1c 23:20 18 Aug 2003

tbh1 - I'll give that a try in the AM.

  DieSse 23:52 18 Aug 2003

Also you could try them both on Cable Select. If you do that tho', you MUST use an 80wire cable, and the drive at the end will be the Master, the drive in the middle will be the Slave.

40wire cables do not work with Cable Select. (well to be strictly accutrate, they could , but they are hardly ever made that way - so rarely that you won't have one!)

If you use Master and Slave jumpering, then it doesn't matter which connector you put which drive on.

Also, it has to be said that you can occasionally get a combination of makes/types that just won't work together, especially if one is an older spec drive.

  temp003 04:06 19 Aug 2003

Also check in BIOS setup, that in the boot sequence, the boot device is hdd 0 and not hdd 1.

  seedie 09:18 19 Aug 2003

Can you put a system on the slave, jumper it for master,disconnect the existing master and see if the 2nd drive (now master) can boot to DOS?

  seedie 09:20 19 Aug 2003

How did you acqire this second drive?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone