Acer laptop touchpad lagging. Yes.

  algernonymous 07:30 14 Mar 2015
Locked

Hi, been using my new Acer Aspire E15 laptop for a couple of weeks when yesterday the touchpad started lagging. Gave it a reboot a couple of times but to no avail. Any ideas please?

  MoD1Ma 01:01 15 Mar 2015

This is really strange people the exact same thing is happening to me and i also have an Acer Aspire E15 laptop that I got about 2 weeks ago, and it just started happening the around the time you have post this, I would really like to know how this is happening to both of us, and find a fix ASAP

  MoD1Ma 01:08 15 Mar 2015

P.S when I use my touchpad and then start using a wireless mouse, the wireless mouse lags too until I unplug it an plug it in again.

  algernonymous 11:18 15 Mar 2015

I've put in a USB mouse and that works Ok but does anyone have an answer to the touchpad problem?

  algernonymous 11:18 15 Mar 2015

I've put in a USB mouse and that works Ok but does anyone have an answer to the touchpad problem?

  MoD1Ma 15:11 15 Mar 2015

Hi again, I have fount a solution that should work for you, try creating a new account on your laptop like I have just done, and now everything is running smoother. Hope this works for you!

  MoD1Ma 18:21 15 Mar 2015

Ahhh god dang! It's happening again.

  EmmaWicker 02:19 16 Mar 2015

Sooo this is pretty weird, but my Acer E15 - Only about 2 months old, has started doing this too. Plus - you know that super irritating caps lock symbol that comes up at the top of the screen? It won't go away for ages after I've hit the caps lock button. Any help or advice would be much appreciated.

  EmmaWicker 02:19 16 Mar 2015

Sooo this is pretty weird, but my Acer E15 - Only about 2 months old, has started doing this too. Plus - you know that super irritating caps lock symbol that comes up at the top of the screen? It won't go away for ages after I've hit the caps lock button. Any help or advice would be much appreciated.

  EmmaWicker 02:21 16 Mar 2015

Arggghhh, double posts!! Stupid lagging laptops fault!! (and a smidge of impatience on my part)

  algernonymous 19:08 17 Mar 2015

I sometimes get the mute on or off (Fn-F8) symbol staying onscreen but it goes if I toggle it on and off again. So does anyone have any suggestions to fix my original problem?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

11 best portfolio websites for designers and artists

Office for Mac buying guide: Price, Office 2017 rumours & new features

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?