acer laptop doesn't see dvd drive

  Picklefactory 20:12 20 Oct 2008
Locked

Hello folks.
Friend of mine has laptop (I'm on now) and it isn't seeing dvd drive at all. Tray opens loads dvd or cd, drive spins with light on as if it's reading OK, but nothing happens. He has something called Daemon Tools loaded to provide a virtual drive (Means nothing to me, but might be relevent) I've checked in disk manager, but drive is not visible.
Any ideas?

  skidzy 20:26 20 Oct 2008

Missing cd/dvd drives can be normally associated with the removal of burning software such as Nero/Roxio/Sonic/Easy CD Creator etc.
And not showing the drive in My Computer.


Try the below link ,if still no luck follow the Procedure of removing the upper and lower filters.


click here


If no joy with the above fix,try the Microsoft Guided Help

click here scroll down to the Guided help download and follow the instructions.

If still no joy,follow the manual fix below.

If you have further any error codes,please post them.


Restore Missing CD/Dvd Drives

Missing cd/dvd drive
If it is showing an error code:
Code 19, Code 31, Code 32, Code 39, or Code 41
, delete the drive.

Then follow these directions for clearing the Upper/Lower Filters: (might want to print this out)

1. Click on Start --> Run --> and type in 'regedit' followed by the enter key ( if Vista Start search or windows+R )
2. Expand the "HKEY_LOCAL_MACHINE" key (looks like a folder) by double clicking it (or
3. clicking the "+" next to it.)
4. Expand the "SYSTEM" Key
5. Expand the "CurrentControlSet" Key
6. Expand the "Control" Key
7. Expand the "Class" Key
8. Please look for a key containing the following string of letter and numbers:
{4D36E965-E325-11CE-BFC1-08002BE10318}
9. High light this key by left clicking once on it
10. On the right hand side you are looking for "UpperFilters" and "LowerFilters" under the "Name" column, once you find these please delete them by right clicking on them and choosing "delete"
11. Please exit the registry by clicking on the "X" in the top right hand corner of the screen

Reboot your computer

.If in any doubt editing the registry,please create a System Restore point first and also backup your registry....The guidedhelp from Microsoft on backing up the registry is a good lesson for anyone to learn. click here


Creating a System Restore point:

Start/All Programs/Accessories/System Tools/System Restore…follow the prompts.


If a virtual drive is there,you may have a drive letter allocation issue.

  Picklefactory 20:33 20 Oct 2008

I'm chatting and drinking beer whilst trying to help, so might take me a while to work through.
Thanks for comprehensive instructions. I'll post back with result later.

  Picklefactory 20:35 20 Oct 2008

maybe should have mentioned running Vista, will that 1st link work with that?

  skidzy 20:47 20 Oct 2008

Yes it does....myself and others tested this when Vista first came out and works on most machines.

  Picklefactory 21:44 20 Oct 2008

Works then doesn't work. 1st link seemed to help, then it went again after a few reboots. The registry one was a none starter as the filters were not there at all. There is no error, just no drive present. Beyond my meagre abilities I'm afraid.

  skidzy 21:50 20 Oct 2008

Then i suspect the virtual drive is reinstalling itself.

Do you have Alcohol 120% installed ? if so ,remove from uninstall a program and problem should be sorted.
You may have other software that is creating this virtual drive.

Have you tried deleting the drive from Device manager and reboot ?

  Picklefactory 21:58 20 Oct 2008

No Alcohol 120% installed, and the drive doesn't appear in device manager, unless I'm looking in the wrong place. I assume it should appear in 'disk drives'
The virtual drive was created with Daemon Tools, but friend only installed that due to missing drive already being an issue prior to that.

  Picklefactory 22:15 20 Oct 2008

Giving up for tonight, I think I'll have more luck sticking to the beer. :-)
Cheers for advice skidzy, still no joy as yet though, seems to be quite common going by the amount of similar issues Google shows me.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?