acer extensa 5620z

  lucyy26 15:14 22 Jan 2010
Locked

I uninstalled acer empowering technology with the intention of reinstalling it afterdwards. I had been getting messages: ACER EMPOWERING TECHNOLOGY FRAMEWAORK LAUNCHER HAS STOPPED WORKING. So I was going to download it again from acer support. I removed all the components and tried to installed it again. I booted it up and it said exception message. and message appers: SORRY, THIS IS NOT AN ACER SYSTEM. Please help, I need empowering technology to hook up to the internet. I have have already tried to contact Acer, but they didn't help. anyone konw what to do in order to fix it?? I also should mention that my windows vista os has been reinstalled from sp1 to sp2 which might cause the problem. I don't know??? solution for that might ge to reinstalled it back to sp1 but I don't know how to do it. can anyone hlep please?
Many thanks

  birdface 14:27 23 Jan 2010

I don't suppose a system restore would help.

  morddwyd 09:23 24 Jan 2010

Do you have any recovery discs/partitions?

My Acer has a built in options to recover everything, just the o/s, or all pre-installed software.

  lucyy26 12:55 24 Jan 2010

Where do I find recovery partitions or perform systme recovery on my Lapatom??

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Intel Coffee Lake release date and specifications

12 Amazing British Craft Beer Label Designs

watchOS 4 review

Les meilleurs navigateurs internet 2017