Acer Aspire power problem.

  madinnit1974 14:18 07 Jan 2011
Locked

Hi I have a Acer aspire 5715z series laptop, the problem I am having is that it wont boot up, it starts and then seconds later shuts down, I think this is due to the battery being dead. I tried to charge it but nothing happens and there is no orange charge light. The fault is not the battery, and not the power cable I have tested both of these. I have stripped it down and removed everything right down to the cpu. No problems with the power input on the board have checked all wiring and solder joints I have tested the board for power and there is power running through the board but still no power to the battery. . Could the fault be with the motherboard and will it need a replacement...

regards Martin.

  northumbria61 14:42 07 Jan 2011

"there is no orange charge light" - I assume you are referring to the light on the battery charger?

  madinnit1974 14:52 07 Jan 2011

yes, there is no charge light, so I assume there is no power to the battery.

  madinnit1974 14:55 07 Jan 2011

also I forgot to mention that when I power the laptop up with battery it comes on for a few seconds and then goes off again, but if I use the mains nothing at all happens.

  northumbria61 15:00 07 Jan 2011

It appears you have a dead/faulty charger if it won't work off "mains" only. If you can, borrow a spare to try but if need be I can link you to some sites for purchasing a new charger (later on today)

  northumbria61 15:03 07 Jan 2011

When purchasing new you need to get correct output - shown on battery as something resembling
19v 3.42A

  madinnit1974 15:09 07 Jan 2011

I have tried a spare charger and the same thin happens

  onthelimit 16:02 07 Jan 2011

As it comes on briefly with the battery, but not with either charger, i'd suggest the problem is with the socket. If you have a multimeter, check if you're getting around 18-19volts on the wiring from charge socket.

  onthelimit 16:04 07 Jan 2011

Sorry, just re-read your first post which says power is reaching the mobo from the charge socket. Did you check that with the battery removed, as residual volyage may be misleading you.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?