Acer Aspire M3910 disk drive help!

  iMarkuz 16:57 22 Sep 2014
Locked

I've had the computer for around 2-3 years and I've opened the disk tray roughly 2-3 times. I need to burn a movie for a friend but it won't open, I've gone onto my computer and clicked eject but it comes up with "An error has occurred when ejecting 'CD Drive(F:)'" Anyone got any idea what the problem is? I've never spilt anything on or damaged my computer in any way.

Cheers!

  johndrew 17:14 22 Sep 2014

Have you tried manually opening the drive - the slide to the right.

Another option is rebooting and then opening the drawer; sometimes this is all it takes.

If a manual will help ....

  Fruit Bat /\0/\ 17:38 22 Sep 2014

seen this occur when the cable is slightly loose.

  iMarkuz 17:39 22 Sep 2014

I have tried both, it just doesn't seem to want to budge. :(

  iMarkuz 17:39 22 Sep 2014

The cable inside the computer or like the power supply etc?

  Fruit Bat /\0/\ 21:10 22 Sep 2014

The power and data cables tp the drive inside the pc.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

How to update iOS on iPhone or iPad

Les meilleures applications pour enfants 2017