acer aspire - dvd not working

  onthelimit 21:51 10 Aug 2010

It was, but when neighbour tried to use a Norton update disc, didn't play and wouldn't eject. Worked with a paper clip, but Device Manager shows a yellow exclam, and uninstall/reinstall says 'windows couldn't...'. Is the drive duff, or is there anything else to try. Thanks.

  northumbria61 22:09 10 Aug 2010

It was obviously the Norton disc that caused the problem. It does happen occasionally. DVD drives do reject discs they don't like. Have you tried it with another disc now that you have ejected it with the paper clip method ?

The yellow exclamation mark - try updating your driver - ie: right click and select "Update Driver Software"

  onthelimit 22:18 10 Aug 2010

thanks Northetc - tried updating, biut windows said couldn't do it and to contact the hardware manufacturer. Without the Norton disc, won't even open. Odd.

  onthelimit 22:27 10 Aug 2010

Tried another disc - can hear the drive running, but nothing happens. My Computer does not show a drive. Odder!

  woodchip 22:43 10 Aug 2010

turn the pc off that means all power removed, then restart it and check device manager for yellow icons if there are any uninstall them by first right click them

  onthelimit 22:52 10 Aug 2010

Taking the battery out and restarting has got rid of the yellow exclam. How now open the tray, please?

  Fruit Bat /\0/\ 22:53 10 Aug 2010

No CD/DVD or CD-ROM access is missing error Code 19, Code 31, Code 32, Code 39, or Code 41
Try this if the optical drives are not appearing in My Computer or Device Manager.
(This is sometimes caused by the removal of Roxio or other writing software.)

click here
Download and save this file to your hard drive. Navigate to where you saved it and double click the file to extract the contents. Locate the EXE file you extracted and double click it. A confirmation dialog will appear when the script is done. You may need to reboot for the change to take effect.
This utility is only intended for Windows® XP, but also appears to work for Vista and Windows 7.
You may need Administrator level access to use this utility. If you do not have Administrator level access, the program will say it is finished, but will not have made any changes.

Similar fixes
click here works for vista or XP
click here

or manual fix
Run regedit and navigate to registry key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\ {4D36E965-E325-11CE-BFC1-08002BE10318}.
Highlight it and in the right pane, find the Upperfilters and Lowerfilters values.
Highlight each one in turn, right click and delete them.
Close regedit and restart the computer.
If in doubt make a restore point before making changes.

  woodchip 22:55 10 Aug 2010

When the PC is restarting press the button, or right click the Drive Icon and choose Eject

  onthelimit 23:00 10 Aug 2010

Was about to try FB's solution when Woodchip's response came up. That worked - thanks a bunch, all - again!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?