Access to WinXP 'Help' query

  Demora 10:09 22 Jan 2009


I don't use the Windows help and support very often but this morning I needed to check something out and when I clicked 'Help & Support' on the start menu. Nothing.

I've read a solution somewhere but I can't find it.

Any pointers as to how I can get this working again?



  MAJ 10:16 22 Jan 2009

Start > Run, type in:


and click OK. See if the Help and Support service is running, if not, then start it. Reboot the PC, see if it has returned.

  Demora 10:44 22 Jan 2009

Hi MAJ Just tried that. the service was set to'automatic' so I did a re-start then restarted the change.

I have no idea when this started because help and support isn't something I use very often.


  birdface 11:00 22 Jan 2009

This from another Forum.
Windows cannot open Help and Support because a system service is not running.

To fix this problem, start the service named 'Help and Support'.

This issue is currently under investigation, however if you are currently experiencing this issue you can run the following commands to resolve the issue:

1. Open a command prompt.
2. Navigate to %windir%\PCHealth\HelpCtr\Binaries
3. Run this command:

start /w helpsvc /svchost netsvcs /regserver /install
4. Once this command completes the Help and Support service should now appear in services.msc
5. Start the Help and Support service

  MAJ 11:04 22 Jan 2009

Or if you go to that folder (it might be a hidden folder) C:\WINDOWS\pchealth\helpctr\binaries double-click on the Helpctr.exe file, see if the Help Centre opens. If not, or the file isn't there, run SFC /SCANNOW.

  provider 2 11:04 22 Jan 2009

It might be an idea to check your firewall. I`ve just installed the latest version of Comodo and it came up with three warnings and requests to proceed or not when I clicked Help & Support.

  brundle 11:34 22 Jan 2009
  Demora 16:44 22 Jan 2009

I have done all the suggestions. Nothing is happening.

But I'm getting messages that ask me to install from d:\ windows xp SERVICE pack 3. My cd for xp is service pack 2 and although I installed sp3 from an update I can't remove it. Message reads a file is missing. But it doesn't say which file.

\i checked the firewall settings too (PCTools internet security) nothing seems to be wrong there.

I would have used system restore to before I installed sp3 but that was last November and am afraid to say, they're gone. Backups from that far back have been cleaned up.

As everything was running smoothly back then I hadn't saved the registry backup I made When I installed sp3.


  Demora 12:53 23 Jan 2009

Well I'm still stumped by this one. I even thought I'd reinstall windows

Not going to happen because I can't get rid of sp3.

Its not essential I hjave help and support working, BUT its there and it should work.

Having said all the above I went to check a laptop thats also got sp3 on and thats all fine.

Any ideas before I have to totally nuke the hdd? Please. (I did threaten the pc with a trip to the bottom of the garden pond....if it wasn't going to behave)



  Fruit Bat /\0/\ 16:33 23 Jan 2009

Help and Support Problems
click here
click here

  Demora 17:01 24 Jan 2009

Thank you everyone that has posted to this thread.

I have fixed the problem, having tried everything I could think of.

In the end things were so bad I just re-installed windows over itself.

Now to fixing the soundcard drivers.

Thanks again.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Best of the Grad Shows 2017: University of the West of England (UWE)

Best value Mac: Which is the best £1249 Mac to buy

Les meilleures GoPro 2017