access database problem

  louandel 17:56 14 Dec 2006
Locked

I am attempting to create a database driven web site using asp.net 2 and an access database. i have created various pages like admin_control and an add page and delete page and they work fine on IIS. The view page also comes up when i upload it to the internet
click here

however when i try to delete or add a page i get the message:

Microsoft OLE DB Provider for ODBC Drivers error '80004005'

[Microsoft][ODBC Microsoft Access Driver] Could not delete from specified tables.

/YotShop/delete1.asp, line 74

I have uploaded the access database to the internet. i have noticed that there is a db folder there which has been there since I changed from linux to windows (via 1and1) but it will not allow me to put the access database in this folder.
Any ideas what maybe goping on?

louandel

  fitshase 21:57 16 Dec 2006

What kind of 1and1 hosting package do you have? The database function is only available on the 1&1 Business Package.

If you only have the home package then you need to upgrade.

  louandel 23:18 16 Dec 2006

I have the business package.

louandel

  kinger 14:43 17 Dec 2006

SYMPTOMS
When you use an Internet Information Server (IIS) ASP page to access a database, the connection may fail with the following error message:
Microsoft OLE DB Provider for ODBC Drivers error '80004005'

[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified
Back to the top

CAUSE
If you have used the C2 security program from the Windows NT Resource Kit on your system, the following registry key may only have read permissions assigned to the Everyone group:
Hkey_Local_Machine\Software\ODBC
In order for the ODBC drivers to function properly, the Web user accounts must have full control of this registry key.
Back to the top

RESOLUTION
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To assign full-control permissions to the Everyone group, follow these steps: 1. Start Registry Editor (Regedt32.exe).
2. Locate the following key in the registry:
Hkey_Local_Machine\Software\ODBC
3. On the Security menu, select Permissions.
4. Select Replace Permission on Existing Subkeys and set the permissions for the Everyone group to full control.
5. Quit Registry Editor.

  louandel 17:02 17 Dec 2006

I dont appear to have an everyone group. Or may have under another name. Does anyone know how I would recognise it or how to install it if for some reason it should be there.

thanx
louandel

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?