98SE Won't Boot

  mistfo 16:49 06 Mar 2004
Locked

While trying to boot I get ATAPI CD-Rom not found then "error loading GDI.exe" then computer shuts down. Have tried “bootdisk.com” and “allbootdisks.com” with and without Win98SE in CD-Rom drawer with no success. Bios settings have been A:>CD-Rom>C: and CD-Rom>A:>C: with no success. Boot disks mentioned no high memory file found, and will use low memory. Also while booting: “Non system disk – Replace the disk and press any key when ready." Also this error message while booting without the boot disk "device driver not found: CDI. No valid CD-Rom device drivers selected, run time error 200 at 0950:0091." All of this started after deleting the Windows font folder. Because neither the CD-Rom or floppy drives are accessible what do I do?
Thanks,
Mike

  woodchip 16:58 06 Mar 2004

If this as just started, put your Windows boot floppy in the computer and start computer when it get's to A:\> type SCANREG\RESTORE so it looks like this

A:\>SCANREG\RESTORE then press enter choose a old date with the arrow keys and press enter then restart comp

  LastChip 17:00 06 Mar 2004

Are you saying, that if you set your first boot drive to A:\> and use a floppy startup disc, you cannot get to a DOS prompt or menu?

Please clarify, when you boot-up, do you get just the single beep as the machine starts?

  mistfo 18:07 06 Mar 2004

Followed your instructions. After restoring the next window stated these three items: Can't find a device file to run Windows applications. Windows registry or system.ini refers to this device. Try reinstalling PTUDF.VXD. I hit enter and next window displayed "error loading GDI.EXE."
Thanks,
Mike
Can you help more?

  hugh-265156 18:14 06 Mar 2004
  hugh-265156 18:18 06 Mar 2004

DOH! i cant read.

sorry i just noticed you said you deleted the fonts folder.

  LastChip 18:46 06 Mar 2004

Maybe your best option is re-install Windows from the CD. By installing over itself, all your personal files should remain in tact.

  mistfo 21:17 06 Mar 2004

Huggy,

Thanks for taking the time and sending me the link to knowledge base. I actually looked in knowledge base by typing in "unable to boot" or something close to that with no success. What did you type in to find it?

Mike

  mistfo 21:21 06 Mar 2004

Last Chip,

Looks like i need to format and reinstall due to not being able to access the CD-Rom. I did learn not to remove the Windows font folder. I was trying to install Print Shop 12 and was unsuccessful due to a locked font folder. I couldn't remove the solo font file so i removed all the files in the folder and ended up with a unbootable system.

Thanks for your replay,
Mike

  Gongoozler 21:27 06 Mar 2004

Hi mistfo. I think that ptudf.exe is part of a packet writing application, i.e. software for using a cd-rw disk as a floppy. If you have an application for doing this, uninstalling it may remove that error message, and may even solve the whole problem.

  LastChip 21:38 06 Mar 2004

Let's just move back a stage.

If the machine does not have any hardware problems, you should be able to boot to a prompt from a floppy disk. At this point, the machine has not tried to access the hard drive, so it's not a problem. This is assuming your BIOS is set to boot from a floppy first.

Now, if you have a good WIN 98 Startup disc or one of the available downloaded versions, you should still be able to get the same result.

All of these discs have one thing in common. Windows 98 needs a virtual drive to enable the operating system to load, which has the effect of moving your CD drive either, one letter, or to a specified letter. Either way, if you look closely at the screen when the floppy has loaded, you will see the allocated letter.

For the purposes of this discussion, we will assume it is a normal Win98 Startup disc and so if your CD drive is normally D: it will become E:.

When you get to the prompt, type,

E: [enter]

and the prompt will change to E:\>

Now, with your Windows Cd in the drive type;

setup [enter]

and the setup program should start to run.

It will write over your existing installation and in this case replace the file you deleted. At least then, you will be able to recover any personal files that need backing up, before perhaps doing a clean install in the future.

If you cannot get to the point of typing setup at a prompt, then your machine has more severe problems than just a missing file, and would have to be investigated further.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?