4GB USB Drive ?dead

  starfish1 12:16 12 Jan 2008

My usb drive appears to have died. Whenever I try to access it I get a message saying 'please insert media'. In disk management it is showing as Disk G but no media. I have tried in each USB slot to no avail. When I look in properties it shows the disk as being full when in fact it only has about 2gb of data on it.

Any ideas anyone?

Thanks in anticipation.

  starfish1 13:34 12 Jan 2008

Anyone please?

  Fruit Bat /\0/\ 16:38 12 Jan 2008

Is it locked? little slide switch on the side usually.

  Terry Brown 16:47 12 Jan 2008

Unfortunately USB sticks are not as reliable as a standard hard drive in data retention--Their main purpose is to transfer data from one machine to another. You may have to re-format it, and start again.

  Fingees 17:13 12 Jan 2008

Did you remove it without clicking on the 'safely remove hardware' icon on the taskbar?

If so you could have corrupted it, if your computer was accessing to it at the time..

Nine times out of ten, it's ok but as it's a large capacity that may have been the cause.

  starfish1 19:37 12 Jan 2008

No it isn't locked. I tried to format it but it said to insert a disk into drive G! I think I might have to buy another one.

Many thanks for your replies.

  Fruit Bat /\0/\ 20:05 12 Jan 2008

USB Permissions
Start - Run and type
Press OK.
Navigate to:
Right click on the folder and pick permissions. Set to ALLOW.
Do the same for:

or try
Refresh USB Ports
Use Drive clean up to remove USB device drive info from the registry
click here
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  starfish1 20:27 12 Jan 2008

Thanks Fruit Bat will try your suggestions and post back later.

  Llwydyn 22:08 12 Jan 2008

I also experienced a similar problem with my USB flash drive a few months ago. I was using it on a mixture of OS's - Vista, XP and sometimes Me. Although it stopped working at work (on XP) and at home (on Vista), it carried on working on my Windows ME pc for some reason.

  Sparkly 08:34 13 Jan 2008

Hi also had the same prob over xmas but a reformat as Terry has suggested put mine back ontrack.

  starfish1 08:34 13 Jan 2008

Tried all suggestions above but made no difference, windows still asks for a disk to be inserted. Many thanks for your time and help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?