4GB of RAM installed only 2.5gb usable

  jonesey911 01:19 15 Apr 2015


I have recently upgraded my computer to have 4GB of RAM. I did not purchase this RAM until I did extensive research into the compatibility of the RAM in question and my computer. When starting my newly upgraded computer I check to see weather my upgrade had worked or not. At the time I was using a 32bit version of Windows 7.

I checked on the internet looking everywhere I could to find a solution.I tried changing the MSConfig file to account for the missing 1.5GB of RAM, but ultimately it didn't work, it kept resetting the maximum RAM to 2.5GB. The next step for me was to upgrade my OS to a 64bit version. I even did a hard reset of the ram at one point.

I know at least one of you is going to say the RAM is broke get new RAM. All I can say is it isn't broke, softwar like CPU-Z can see that there is 4GB of RAM installed but Windows can't, so it must be a problem with one of the Windows settings or BIOS settings, I just don't know which one.

  robin_x 01:57 15 Apr 2015

Have you upgraded to 64 bit yet. I's not totally clear.

What computer and motheroard do you have?

What sticks in what slots?

Have a look here for ideas if you haven't seen them.

eg is some hardware still being allocated RAM space.

click here

  jonesey911 02:18 15 Apr 2015

Yes my OS is 64bit

CPU-Z images of my PC

I understand that some systems do take RAM but 1.5GB seems like a hell of a lot to take for other systems, especially because the PC stated with only 1GB of RAM total.

  Batch 08:34 15 Apr 2015

Freedomgotburried post is SPAM. FE informed.

  Batch 08:37 15 Apr 2015

Is the memory a single 4GB strip or 2 x 2GB (or even 4 x 1GB).

If it is not 1 x 4GB strip, try each strip on its own in turn and see how much memory is recognised. Also try switch the strips around (in to different slots).

  alanrwood 08:46 15 Apr 2015

If using 32 bit Windows the operating system can use a max of 3.4GB. Also your graphiocs card will reserve some memory for its own exclusive use.

You have not set up a small RAMDisk have you.

  wee eddie 10:01 15 Apr 2015

Not my field but a little memory tickles.

Could the Memory be double sided and the MOBO is only using one side?

  Jollyjohn 11:09 15 Apr 2015

Go Start and Search Resource Monitor - open this and look under the Memory Tab - How much is "Hardware reserved"?

  Daisy_Michael 12:21 15 Apr 2015

It can be your built-in graphics utilizing the RAM!

May I have the details about your computer?

  Daisy_Michael 12:32 15 Apr 2015

From Start Menu: Resource Monitor >> Memory >> Hardware Reserved (see if you could get an idea from here).

  SeiyaIkki 12:42 15 Apr 2015

If you show your computer details it will be more helpful.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse draws on iconic heritage for a fresh brand identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans échec ?