4GB flash drive full - but saying needs formatting

  PC_HelpMe 22:23 30 Dec 2009

Hi folks,

Hope you've have a good Christmas and are preparing for the New Year celebrations.

I've got a Maxell 4GB flash drive and it is now full. I had a few problems with it the other day in trying to correctly remove it from my laptop - but made sure that it said it was ok and safe to remove such before I did.

Anyway, now when I put it in either my laptop or my main computer, it is coming up as being some new hardware and when I click on its properties, it is saying its full to capacity - but as it keeps coming up saying it needs formatting it won't let me access anything on it!!!!!!!!!!

I know that with your normal computer, there is a way you can do like a system restore - is there anything similar I can do with this flash drive to be able to access its contents. If I select to format it - I am going to lose everything on there!

Thanks for reading.

  User-312386 22:28 30 Dec 2009

If you format it then yes you lose everything! Do you not have a back up of what is on the flash drive?

  PC_HelpMe 22:33 30 Dec 2009

Typically no I don't. My own fault I know.

  Fruit Bat /\0/\ 22:36 30 Dec 2009
  User-312386 22:36 30 Dec 2009

No its not your fault, one of those things - Have you tried plugging it into another computer apart from your own ones?

  PC_HelpMe 22:52 30 Dec 2009

Hi - and thanks for the replies.

I have only tried plugging it into our 2 computers and it does the same on both of those :-(

I am just using some software I have found to hopefully recover the data - and am then going to try the link Fruit Bat has kindly provided me with. I just hope I can recover it all. Can't believe that I didn't check that the last document I tried to fit on the thing was small enough to go on it. I am so frustrated with myself for being so stupid.

  PC_HelpMe 22:57 30 Dec 2009

On the software Fruit Bat has provided me with the link for - it asks me to put in what the partition is. Either FAT16, FAT32, or NTFS. The only other option is "unknown" but it won't let me proceed if i keep "unknown" selected. Any idea which I need to select?

  Fruit Bat /\0/\ 23:22 30 Dec 2009


  PC_HelpMe 07:46 31 Dec 2009

Thanks Fruit Bat.

Having just run the software that you provided me the link for - before I go and purchase the full version to actually enable me to recover the data - I am not sure whether it has managed to actually recover all of it. It seems to have recovered all the folders that were on the drive - but there were quite a lot of documents that weren't in a folder and they don't seem to be coming up - only the stuff that were in folders. Is there any other software you would recommend that would actually recover any of these "loose" files too?

  Sea Urchin 12:41 31 Dec 2009

You could try this free recovery program

click here

  PC_HelpMe 13:13 31 Dec 2009

Thanks but I have tried the Recuva software and when I select the drive that the flash pen is in it just comes up saying "Unable to read boot sector".

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?