4870 issues - no display

  MrBlob 18:00 28 Aug 2008
Locked

I bought a shiny new 512MB Sapphire HD4870 to replace my (slightly) aging 8800GTS 320MB, and I can't get it to display anything. What's worse is that I can't get it display anything even after reinserting the 8800.

Here's what I've done:
- Removed 8800GTS
- Put in 4870, including 2 6-pin power cables coming direct from PSU
- No display from either output - tried a combination of naked DVI and DVI->D-Sub adapters, and different ports on two different monitors, both of which I know work
- Tried taking power from molex power connectors instead, using molex->PCI-E adaptors that came with the 4870 - no display
- Removed 4870, reinserted 8800GTS, plugged in original PCI-E power connector direct from PSU, as it was before - no display
- Detached or removed all components (HDs, DVD-RW, sound card, USB connector, RAM, extra 6-pin PCI-E power connector) - still no display
- Tried removing CMOS battery for several minutes (to reset CPU OC from before) - still no display


Specs:
Antec Neo 550W PSU
Core 2 Duo E6400 CPU (w/ Thermalright Ultra-120 Extreme)
Gigabyte 965P-DS3 MoBo
OCZ Platinum 6400 EL XTC R2 DDR2 2x1GB RAM
Audigy Xtremegamer sound card


When I turn the machine on with the 4870 connected, three lights come on. From extensive Googling, this appears to be normal.

It's bizarre that the 8800 is failing to work now. My guess, based on the fact that all the fans come on (3*Antec TriCool, 1 OEM fan on the Ultra-120, plus the ones on the gfx cards), is that I've screwed up the motherboard somehow. What do you folks think?

Any help is much appreciated!

  citadel 18:37 28 Aug 2008

what happens when you turn on the power, is there not even the bios screen, normally the first thing you see in the top left corner of the screen is the graphics card info. I had a similar problem when the bios screen just stuck before loading windows.

  MrBlob 18:41 28 Aug 2008

Nope, I get nothing - the monitors don't register an output at all.

  citadel 18:55 28 Aug 2008

as power is getting to the card looks like the slot on the board has packed in.

  MrBlob 01:17 29 Aug 2008

Yeah, it does seem like a possibility.

That said, the system doesn't appear to be booting: I can't see the HDs accessing, and the HD light on the front of the case doesn't flash the way it used to - it doesn't flash at all, actually, except for once, just after I power the machine up.

What sort of effects might I expect to see if the PCI-E slot has indeed died?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?