3TB drive & W7 error code

  very perplexed 22:08 11 Apr 2013

Hi there, I bought a Weston digital 3TB hard drive in March 2012 which was under warranty until 19 Aug 2014. Originally I fitted it in a Drobo backup system which formatted the disk with its own operating system. But eventually the Drobo backup system crashed. (I think, because it would not work with the 3TB drive but all the light indicators showed it was working correctly. So 3 weeks ago I removed the 3TB drive from the Drobo unit and tried to reformat it on my windows 7, 64 bit tower as a secondary drive but it would only show 746.52GB the other 1.99TB had disappeared and as I tried to format the hard drive the windows activation reported that I had 6 days to re-activate windows. The problem is, windows would not activate with the 3TB disk connected, it reports error code 0x80070005 each time I tried to activate windows. Plus I do not think windows would require re-activation for a secondary hard drive anyway. Checking on the web some forum sites report that even Microsoft do not know how to fix this error code, though I am not sure if this is true. I contacted Weston Digital who asked me to use their Driver tester, which showed a "write Zeros error" fault and they sent a replacement drive. I installed it in my pc and formatted it into a 2TB and a virtual 1TB as per instructions which solved the "missing" 2TBs. But when the new disk was up and running it came up with the same windows activation error code. When I disconnected the 3TB drive, windows device manager showed that my windows was activated and working normally. I repeated the process of re-connecting the 3TB drive and it caused the same windows activation error code. It would seem that this product has a generic conflict with windows 7. So again I contacted Weston and asked for a refund as the replacement drive had the same problem and there did not seem much point in swapping the drive for a 3rd time. They informed me that I should contact the original supplier (Benthams, Amazon Marketplace) for a refund as Weston Digital do not make refunds except for their on-line store, but I purchased the original drive 13 months ago so I am sure they would not do a refund even if I sent them the brand new exchanged disk drive. 1. Do you know if this 0x80070005 windows activation error code is fixable? Web forums sites say people with the same error have tried re-installing windows and even purchased a new copy of windows all to no avail. 2. What options if any do I have to resolve this problem i.e. refund, exchange for a 2TB and a 1TB which Weston Digital has already refused saying this option would not be legal. 3. Would it be any good to contact Weston Digital's tech department and ask them to see if there is a conflict with windows 7? Or do I just throw the new drive in the metal scrap at the local tip and mark it up as a learning curve never to buy another 3TB drive?

  Fruit Bat /\0/\ 22:39 11 Apr 2013

Anything here?

  very perplexed 15:17 12 Apr 2013

Thank you for taking the time to reply. It looks a little complex but I will have a go and let you know if it worked.

  john bunyan 15:28 12 Apr 2013

Purely as a matter of interest, why do you need such a huge drive? I have a 500gig HD with some other 500gig ones for back ups etc, and my system files are below 50Gig, and data less than 100 gig (including music, photos etc.) I guess you need it for video? It does seem risky to put so many eggs in one basket, or am I missing something?

  very perplexed 21:09 12 Apr 2013

I orginally bought it to fit into my drobo backup system which takes lots of spare disk capacity as I take alot of photos but the drobo did not work well with the 3TB drive. So I tried to get it to work with my tower thats when I found the fault on it and weston changed it for a new one. I do have 4x1TB disks which I use for backup copies. But now I am trying to fix this windows activation error code. I really wish I had not bought it in the first placeand would not recommend 3TB drives to anyone until windows is able to work better with them. I am going to have a go at the solution offered by fruit bat now I have a couple of hours spare. Thanks for your interest.

  very perplexed 16:04 13 Apr 2013

I had a go at Fruit Bats suggestion and was unable to access "rsop.msc" getting an "access denied" response. I found out that this was because I had W7 home and not the more expensive windows 7 versions which deals with servers. I have however managed to get around the problem by deleting the 1TB vertual drive making it a 2TB drive. This seemed to be a better option that throwing the drive in the skip and windows 7 (bless it!) is now able to cope with it. So thank you all so much for your imput without sites like these computing life would be much difficult.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

Political cartoons in 2017: Chris Riddell, Rebecca Hendin and Dave Brown on what it’s like to…

The best iPhone for 2017

Tennis : comment regarder la finale de la Coupe Davis 2017 ?