2Gb USB Stick driver?

  Ninefoot 16:08 24 Mar 2008


I have tried to use 2 new 2Gb USB Memory sticks in my Mesh desktop PC running XP with SP2 and USB 2.0 interface. Both of these bring up the "found new hardware wizard" in Windows and want a CD with the drivers on. The PC's recovery disk and the XP SP2 disk do not contain what the wizard is looking for.

The CD that came with one of the sticks has drivers for Win98 and use of these brings up the message "XP does not need drivers for this device"

Both sticks work fine in a laptop, also running XP with SP2 but only with USB 1.1 ports so I get a "this device can run faster" message but the drives work fine.

I have a USB 2.0 card reader which works fine when plugged into any of the USB ports on the desktop.

I have tried refreshing the USB stack and various other suggestions I discovered by searching the forum here but without success.

Any help or ideas welcomed.

  Technotiger 16:18 24 Mar 2008

Have you checked that your PC does have USB2 - to check this, look in Devices and see if the word Enhanced appears anywhere in the USB section.
You card reader may be working in USB1.1 mode.

  brundle 16:26 24 Mar 2008

Point the requester to c:\windows\inf

  Fruit Bat /\0/\ 16:26 24 Mar 2008

Refresh USB Ports
Use Drive clean up to remove USB device drive info from the registry
click here
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

USB Permissions
Start - Run and type
Press OK.
Navigate to:
Right click on the folder and pick permissions. Set to ALLOW.
Do the same for:

  Ninefoot 16:30 24 Mar 2008

In Device Manager I have the following:

+ Universal Serial Bus Controllers
-Standard Enhanced PCI to USB Host Controller
-Standard OpenHCD USB Host Controller
-Standard OpenHCD USB Host Controller
-USB 2.0 Root Hub
-USB Printing Support
-USB Root Hub
-USB Root Hub

All appear to be OK, no yellow question marks anywhere.

The memory sticks work fine on the laptop which is USB1.1


  Technotiger 16:44 24 Mar 2008

Well yes, you do have USB2. Best to follow previous suggestions then.

  Ninefoot 17:17 24 Mar 2008


Many thanks for your help, Brundle's suggestion worked.

  Technotiger 17:28 24 Mar 2008

Grreat, thanks for the feedback.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?