1st time build advice, are these components all compatible?

  Tom11890 03:35 25 Nov 2012
Locked

Hi everyone

I been looking into building my first PC recently and basically i'm just looking for advice. This is what I've come up with as far as what components I would like to use:

Processor: Intel i5-3570k - 3.4GHz Motherboard: Asus P8Z77-V Motherboard RAM: Corsair 8GB 1600MHz CL9 DDR3 Vengeance Memory Two Module Kit Graphics Card: Asus GeForce GTX 650 Ti Nvidia Graphics Card Solid State Drive: OCZ Vertex 4 256GB SATA III 2.5 inch SSD Hard Drive: Western Digital Caviar Black 500GB SATA III 6 Gbps Internal 3.5 inch Hard Drive Case: Cooler Master Elite 430 - RC-430-KWN1 Power Supply: Corsair TX650V2 650W PSU Cooling: Cooler Master Hyper 212 EVO DVD Burner: Asus DRW-24B5ST 24x Internal SATA DVD Drive Card Reader: Icy Box IB-865 3.5 inch Multicard Reader OS: Windows 7 Home Premium 64bit

I don't have any previous experience with building computers, so I would just like to clarify the following things:

  1. Are all these components compatible with each other?
  2. Is a 750W Psu sufficient?
  3. Am I missing anything?

Also if you have any suggestions for different components I should use, they would be greatly appreciated, however I don't really want to spend any more money then I already am on it. I will be using the PC mainly for Casual Gaming and using AutoCAD, but might do a bit of video editing in the future too.

Thanks in advance, Tom

  nickf 20:29 26 Nov 2012

Dont see any great problems with compatibility . PSU should be fine , I run an overclocked i7 3770k ( 4.5Ghz ) and a GTX 680sc on the same PSU with no problems . as to missing anything , sound card ? And as a rough guide I would spend the same on a monitor as I spend on a graphics card

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Lightwell software lets you create mobile apps without using code

Best value Mac: Which is the best £1249 Mac to buy

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?