16-bit programme not printing

  martin_old 10:51 26 Sep 2006
Locked

Hi,

I have an old version of Instant Calendar for Windows (Win 3.1) which has been working fine on both my laptop and PC. It still does, but it will no longer print.

Has a Windows Update caused this, or something else?

Help please.

  gudgulf 12:23 26 Sep 2006

Try this fix click here for the Windows 16 Bit subsyatem.

Have you changed any programs recently...and what Firewall are you running?

i had loads of 16 Bit program problems caused by Sunbelt/Kerio firewall.

  martin_old 12:29 26 Sep 2006

Hi, that's great!

Yes, I have changed anti-virus from NAV to AVG, and also now running ewido anti-spyware.

Why should these have anything to do with printing?

Regards

  gudgulf 13:13 26 Sep 2006

It took me ages to track down why my old 16 bit programs had stopped working.......and why my firewall had an effect I don't know.

It could be a Windows update as you suggest,or it just may be the result of a different program.It was just a thought.

I do know that Norton installs itself to all aspects of your pc.....maybe removing it has broken the link from the program to the printer.

Try opening the printers section in Control Panel and deleting the printer.Restart Windows and it should detect and reinstall the drivers for the printer...if it doesn't it suggests a problem with the drivers.

Have you tried updating you printer drivers?

Perhaps a reinstall of the program might help.

The thing I did to track down my problem was to use System Restore to take the computer back stage by stage until the problem went away.....then look at what had changed between then and the problem occurring.

That might be worth a try if all else fails.

  martin_old 08:34 27 Sep 2006

Hi,

I have downloaded the 16-bit Quick Fix. There does seem to be an improvement in the programme running, but no change regarding the printing.

When I press 'print', the process starts, but then just hangs, with no error messages until I give up and 'cancel'! It was then that i got the '16-bit' error message.

The printer drivers have recently been updated. I am now trying printer deletion, followed by System Restore, and will let you know.

  martin_old 09:06 29 Sep 2006

I've deleted the printer and re-installed on both machines. For some reason System Restore won't let me go back.

So I am stuck. Why is it that just this one programe won't print?

  gudgulf 09:18 29 Sep 2006

Have you tried disabling Ewido/AVG/firewall yet.

I know it's unlikely but it's worth a try.

  martin_old 09:42 29 Sep 2006

Yes, I've tried that, but as you suggest, no success.

  gudgulf 10:32 29 Sep 2006

Have you checked to make sure that your printer is set as default?

Also in the print section of the program make sure it is pointing at/identifying the correct printer.

  martin_old 10:37 29 Sep 2006

Yes, I have.

There is only one printer, and every other programme is printing normally.

  gudgulf 23:05 29 Sep 2006

It may be that Windows updates have made the program not fully functional.

Does it run under normal XP,or do you run it under Compatibility mode?

If not under Compatibility mode try it......right click the shortcut to the program,select Properties and then the Compatibility tab....try more than just Windows 3.1 mode though if it doesn't work with that one.I have one game that was designed for '98 but will only run on my XPpro pc under NT4 mode!

One other trick is to save whatever document or page from the progam you want into My Documents or a dedicated folder,and and print from there directly with Windows.Or copy and paste the text into Notepad or Word and print from there.

Not a solution I know....but might do as a workaround.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?