PC crashing when opening games

  MSkjel 21:45 24 Jan 2015
Locked

Hi. I've been having some problems with my computer today. It worked fine yesterday, until I overclocked my AMD FX 6300 and the pc crashed. After this I have had no luck in opening Steam games. BF3 works just fine. I am running two Sapphire Radeon R9 280x's in crossfirex. I've tried running only one card, and switched between them. I've also downclocked my CPU to the normal frequency, but as soon as i press a game in steam my pc just crashes. It still shows the screen, but it's not responding to anything. I have been running the AMD Overdrive stability test for five hours, and it shows no errors on the CPU.

Specs: CPU: AMD FX 6300(I know I am bottlenecking my cards with it) Motherboard: Gigabyte 990XA-Ud3 rev 3.0 (Newest beta BIOS) GPU: 2 x Sapphire Radeon R9 280X ( Catalyst 14.12 Omega) PSU: XFX PRO 750W I do have a TP Link wireless network card too, and I have had some trouble with the drivers they have on their website ( The PC would crash after some time). But the drivers that came on the cd works just fine.

Any help would be greatly appreciated

  • Markus
  nickf 12:40 25 Jan 2015

I would uninstall steam and reload , start with a fresh load, see what you get from there , then load your games one at a time ,

  MSkjel 13:22 25 Jan 2015

I have already tried that. I have also uninstalled all my drivers and reinstalled them again. But still nothing.

  MSkjel 13:45 25 Jan 2015

Okay, so I just tried to boot my computer from another harddrive I had laying aroud. It booted, and I used the partition on the harddrive I have in my gaming pc to start Advanced Warfare, and it worked just fine. This confirms there is nothing wrong with my hardware. But I still dont know why it crashes when I launch it while booting from the harddrive in my pc.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?