Philips STB setup problem

  Jim Thing 21:13 27 May 2008
Locked

I've been setting up a Philips Freeview STB for my elderly neighbour. I'm not exactly sure of the model number and can't check it at the moment as she's now gone away for a day or two. On the basis of STB photographs on various websites I think it's a DTR 210.

The setup seemed to go without a hitch, and the box apparently does all that it should — with one strange exception: when I select Channel 4 it appears to display the channel correctly, but after a few seconds the screen goes completely blank. And, after re-selecting the channel several times with the same result, it dawned on me that I was getting *exactly* the same result, i.e. I was seeing the same few seconds of the programme each time.

Could someone please suggest what may be causing this problem and what I might do to solve it?

TIA
Jim

  oresome 14:20 28 May 2008

I would try rescanning all the channels again.

  Jim Thing 17:39 28 May 2008

Thanks for the suggestion. When my neighbour gets back from wherever she's at, I'll unplug the STB and start afresh.

  pchelper001 11:41 01 Jun 2008

i have this...it seems to be a glitch in all of these boxes. I find that if you press guide, and then exit, the picture comes back. I seem to get it mainly on the channels i use most frequently.

  Jim Thing 12:11 01 Jun 2008

I'll try your suggestion as soon as I can get at my neighbour's Philips box once again — she hasn't returned yet.

Many thanks.

  Jim Thing 12:31 04 Jun 2008

My neighbour returned yesterday, so I've been able to get at the Philips box. Your suggestion (EPG -> EXIT) provided a fix and my neighbour is delighted that she can now watch Countdown. Many thanks.

However, without wishing to appear ungrateful, the workaround certainly does the trick but the problem is still there. It re-appears each time Channel 4 is selected, and re-scanning all the channels hasn't cured it (thanks anyway, oresome).

So I've asked my neighbour to check whether her son (who bought the box for her) still has the receipt. If so, the box is going back to the shop.

Thanks again for your help.

  pchelper001 17:10 04 Jun 2008

i found that it sometimes appears to be if the set top box has got hot during being turned off, or when in standby, however you want to put it. If she changes the channel to another channel before switching it off, when turning the box back on to ch4, does the fault still appear?

  Jim Thing 17:26 04 Jun 2008

I couldn't say, but I'll get her to try it and let me know. Thanks.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?