New to this technology...Help!

  six-h 20:52 28 Mar 2009

I've been gifted an old phone, it's an O2 X1b.
My daughter thinks that it was using an Orange sim card, and recons that it should be OK to use a Tesco sim which she thinks is also Orange.
Tesco staff don't know if their card will be recognised by the phone, and say if not, it can't be refunded.
How can I find out for sure?
(Tesco didn't have the answer to that one either!)lol
Auy advice?

  six-h 12:18 29 Mar 2009

Thanks ßeta,
found two very,very old cards, a Vodafone that had at some time been used, and an Orange one equally old, but never used.
Both gave me access to the controls, and displayed "Limited Connectivity" but of course I couldn't use them.
Phoned O2 and gave them the IMEI No. to see if they could advise if it was locked to them, no definitive answer!
On swapping the cards round again neither is recognised. Display just says "Insert SIM".
Called O2 who swear they have done nothing to cause this, but I'm suspicious!
What's going on?

  six-h 23:40 04 Apr 2009

I had an e-mail notification that FE had posted a message!
Evidently the system telling porkies!!

Thanks again ßeta
Just an update, Tesco mobile helpline did a bit of lateral thinking saying "didn't some chump offer to slip their Tesco SIM card into your phone to see if it was recognised?" Answer, No!

Went back,...they did, worked...I'm up and running!

Now all I have to do is learn how to use it!

  Forum Editor 15:19 05 Apr 2009

but immediately realised that I had posted it in the wrong thread - it was intended for another thread, and would have read as complete nonsense here, so I deleted it.

  six-h 16:50 05 Apr 2009

The luxury and trappings of "high office"!
the ability to delete! lol

  six-h 23:27 08 Apr 2009

I'm struggling with setting up the voicemail service.
Tesco advised dial 2905 to set up the service, yep, fine, done that!
Going into Messaging>Voicemail>Get Voicemail, now connects me to the service.
The other option, "Settings" just shows a text page with the number 901 on it.
Pressing and holding the "1" key dials this number, (901) but it is not recognised.
It must be an O2 pre-programmed number.
I've tried changing the number in "Settings", but although it says "Saving", using the "1" key shortcut still dials 901.
How can I change this?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

How to find a font: Discover the name of a typeface with these apps

The best iPhone for 2017

Les meilleurs logiciels de montage vidéo gratuits (en 2017)