LG 26LC55 screen problem

  wasp15 20:29 25 Nov 2009
Locked

I have a problem with my LG LCD TV that's just under two years old (unfortunately the warranty was only for one year).

When I switch it on from cold, the sound is fine but there's no picture. Gradually I see horizontal and vertical coloured lines move across the screen, big blotches of colour, or sometimes just a grey screen. After 15-20 minutes the picture comes on and, from then on, the TV works perfectly. It's as if it needs to warm up - something I hear was a common problem with the 'tubes' in old CRT TVs, but I understand that this doesn't apply to flat-panel screens(?)

I've tried leaving it on standby but the picture doesn't seem to come on any faster. I've also tried resetting the TV to factory mode and turning software update on (it says no update is available). The same problem happens whether I'm trying to watch digital or analogue TV, or even listening to the radio.

I have tried Googling for a solution but didn't have any luck and had a look through the manual troubleshooting advice. Does anyone please have any idea what may be causing this problem or have a solution that I might be able to try myself? I can't really afford to take it to a repair shop at the moment, and will otherwise have to grin and bear it until after xmas so any advice would be greatly appreciated!

Thanks in advance.

  PP321 21:39 25 Nov 2009

Needs a local repairman to look at it or an LG dealer. Nothing you can do personally im afraid.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Aardman's new YouTube channel to share the work of independent animators

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017