iPhone 5s not receiving calls/texts

  Steve_91 22:42 31 Mar 2016
Locked

Hello everybody! I have quite the conundrum here and and I've been up the walls trying to solve this but with no luck.

I recently got a refurbished iPhone 5C. I needed a new sim card, as my old one wasn't nano, so I got that and transferred my old number over to it. I set up the phone, put the sim card in and away I went. But I soon realised that I could make calls and send texts but couldn't receive them. I live in a rural area and when I went into the local town it worked fine. It was odd because I had never had trouble at home with my old phone. And my family all have the same provider.

I rang up my service provider and they told me that the transfer between sim cards had gone smoothly and that I should do a handset test. So I put my sim card into another phone and it worked perfectly. This, for me, ruled out the idea that it was because of my location. So I thought it might be the phone itself. So I brought it back to the shop where I bought it. They replaced the antennae but to no avail. I decided to ask to exchange it for a refurbished iPhone 5s instead. Again there was the same problem.

I got my father's phone and put my sim card into it. No problem. Back into mine. It won't receive a call or text. My neighbour has the same phone (albeit with a different provider) and has no problems with it.

I feel like I've exhausted all possibilities. The sim card? It works in other phones. The phone? I've tried two different iPhone models. The location itself? Nobody else in my area has the problem even on the same phone model. The service provider? How can it be if the sim card works in other phones?

So I'm pretty exasperated here. I've spent a few days trying to solve this but I can't get my head around it. Does anyone have any idea of what the problem could be?

  Govan1x 07:56 01 Apr 2016

Probably no help. But on my Samsung there is a blocking mode function on it and if this is set it stops incoming calls etc depending on what you have ticked.

Not sure if an iPhone has the same or not. Maybe a function on it if using abroad if you wanted incoming calls etc blocked so that you would not be charged for them.

  Govan1x 07:57 01 Apr 2016

Maybe turn flight mode on for 10 seconds and then off again to see if that helps.

  Steve_91 11:33 01 Apr 2016

Thanks for the help! But I solved it. Turns out I needed to switch it from 3G to 2G as my area can't seem to handle the higher setting. Pretty simple in the end after all that. Thanks for the effort though!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

ManvsMachine win UK's only Gold Design Cannes Lions award

iPad Pro 10.5in (2017) review

Comment connecter un MacBook à une TV ?