1 of 4 DECT Phones not networking

  Danoh 01:01 15 Feb 2006

Don't know if this is digital enough for inclusion in this forum, but I'll chance it....

Just 1 out of my 4 Philips 515 DECT phones has stopped registering with the base station. Can't make any calls and several functions which depends on base station connectivity no longer show up on the handsets' display. Pure handset functions still work.

I've tried taking and leaving the batteries out and reinserting them after a while. I've also tried starting from scratch; removing batteries out of all 4 handsets, powering off the base station, then repowering everything back on from base station outward.

Any ideas/suggestions welcome!

  LAP 15:16 15 Feb 2006

Have you an option to reset to factory default. Otherwise I haven't got a clue.

  Newuser2 16:48 15 Feb 2006

Try calling Philips

  oresome 20:46 15 Feb 2006

Try re-registering the handset with base unit.

This is likely to involve putting the base unit into registration mode and entering a PIN on the handset after also putting that in registration mode if it's anything like mine.

  Danoh 01:13 16 Feb 2006

oresome; thats the same as for mine and I did enter the "RC" code by going through the registration process, starting with powering the base unit off and then on. But no luck. Perhaps I can try to de-register ALL handsets and try again from the top.

LAP; thanks. By taking out all the batteries & disconnecting the power, I was hoping to do a factory reset.

Newuser2; I'd emailed Philips but have yet to receive a response. I guess the next thing is to try and call them. They will probably refer me to some 3rd party company who will probably want to charge me for the advice! But will try that towards the end of my tether... :-)

  Newuser2 16:03 16 Feb 2006

Philips repair is a third party from what I can remember, and they are a night mare to deal with.
From experience if your phone needs repairing it will be cheaper to bin it and buy a new one.
If you call Philips they have in the past been helpful if very limited in the options they give and they don't charge.

  Danoh 12:47 20 Feb 2006

thanks Newuser2; will try to buzz Philips, just in case.

  dms05 11:56 21 Feb 2006

Danoh, you might need to de-register the offending handset first, before re-registering. My DECT only allows 4 handsets to be registered so you couldn't register a 5th without removing one (which would have to be the faulty one). Of course the handset could be faulty.

You can register any make of DECT on any Base (sometimes some of the more sophisticated options go AWOL) so if you can pick up a £20 DECT phone you can then register that on your existing Base after removing the faulty one.

  kimota 19:51 14 Mar 2006

I bought a three handset version of this several days ago. Boy, did I have trouble. I rang philps tech support, got answered right away! and they gave me some tips which, so far, have worked.

1. On a new rig, allow at least 24 hours for charging all the batteries in all devices, while on initial charge leave everything well alone.

2. If you do need to do a factory reset, take all the batteries out of everything, and then wait 30 minutes before replacing and setting up strictly by the user manual.

  Danoh 09:57 15 Mar 2006

Thansk dms05 & kimota;

This DECT set allows for 7 handsets although only 4 were bundled at purchase.
There was no option to de-register the faulty (3rd) handset and I had tried removing all power sources for at least 24 hrs.

When I tried to de-register all handsets and remove all phone book entries, etc., I got weird displays;
Phone book names and numbers were split across multiple entries but I managed to delete all of these.
However, there was one last handset entry with a weird 3 character reference, which refused to be deleted.

I called Philips who thought the base station itself has got corrupted and could not offer any further workarounds as I had tried all they would suggest. Only option was to get another DECT set and re-use my remaining 3 handsets on that instead.

Loathe to give up, I thought I'd try the freezer trick which I'd read others had used for failing HDDs.
Wrapped the base station and handsets (minus batteries, power units etc) securely in a plastic bag and left in a freezer for >24 hrs, then left out at room temperature for >24 hrs.
Followed the same standard setup from scratch, and it worked!!

But then, the same (3rd) handset's batteries gave up within 1 minute of use, despite being left charging for >24 hrs.
Got new (900 rather then original 600 mAh) rechargeables, charged them fully in a separate charger and inserted them ~ handset battery indicator shows low charge and proceeds to charge while on the handset's base.

The original batteries were completely dead when placed in the separate charger, which can detect short-circuits, etc, but simply does not react to these batteries. Its almost as if they were not there.
This could be the cause of the malfunction ~ over charging by the handset. Its 18 mths old so beyond the warranty period.
Although its working now with the new batteries, I'm tempted to discard it, if it messes up again rather then continue with wasting rechargeables and my time :-)

Thanks again to all for taking the time and trouble to post suggestions. Much appreciated.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?