MINKS 13:20 14 Mar 2005

Purchased 2 Pure Digital "The Bug" DAB radios for my children at Christmas. Read all the information on their website on what this Bug is capable of.
"Superb connectivity to computer, connect to computer by USB to upgrade firmware when updates available. Record radio to memory card, we recommend Kingston memory cards."

Firmware update became available, downloaded update connected the Bug with a USB cable and followed instruction. Software upgrade option on the Bug asked me to confirm USB cable attached, I confirmed and nothing happened, left it for 30 mins still nothing happened.

E-mailed Pure Digital support-
They said try another USB cable.
I did still nothing happened

E-mailed Pure Digital again
They blamed my computer and told me to try it on another computer
I tried 2 other computers, still nothing happened.

In the meantime i purchased a Kingston memory card. Inserted the card in the Bug. The Bug replied error reading card.

E-mailed Pure Digital again.
They told me the 2 other computers must have a configuration problem along with my computer. The Kingston memory card is at fault, the one I have was probably made in Taiwan and the one they tested was made in Japan. Strange they recommend the Kingston card as compatible on their website.

So up to now they have blamed 3 different computer manufacturers and a memory card manufacturer and have never considered that the Bug is at fault.

The last e-mail I sent to them on 6/2/05 stating " please advise me on how you are going to rectify this problem" has not been answered.

Is it 3 computers and a memory card the fault or the Bug?

  Salinger 13:49 14 Mar 2005

I almost bought one from Comet, the memory Card and PC connectivity were the reasons. However, Comet only had the display model and refused to discuss a reduction. The "Bug" now appears to have disappeared off the face of the earth (not available anywhere since Christmas).

Since your sets don't appear to be fit for the purpose sold I would be looking for a full refund.

  zipdrive 17:44 14 Mar 2005

I recently brought the Bug radio for my wife as a birthday present. She is very happy with it. I brought it from John Lewis. The white version was on special offer £99.99.I could not find anywhere on the Internet that was cheaper.

I manage to upgrade it from version 1 to version 1.2. The first time I tried it, it did not upgrade. It did however work after removing and plugging the usb cable back in I think I may have also kicked off the upgrade before putting the cable back in? I am using XP home.

If you give me a run down on what you have tried, maybe I can give some further advice.

  spuds 00:36 15 Mar 2005

Rights of possible re-address click here

  MINKS 12:22 15 Mar 2005


Tried all sorts of combinations

Plugging the cable in before switching on the Bug.
Plugging the cable in at the software idle stage.
Unplugging the cable after confirming cable attached and replugging

The point I get upto is confirming the USB cable is attached. Found new hardware wizard pops up follow the new hardware instructions. Then a window opens with files transferring from folder to folder and this goes on for ever. I have left it running at this stage for hours but the upgrade goes no further. The screen on the Bug reads "software upgrade idle, key exits".


Quoted the Trading Standards consumer rights to Pure Digital on last e-mail to them,goods should correspond with any description applied to them. But they have not responded.

  zipdrive 17:51 15 Mar 2005


Not sure which O/S you have on your PC?, but I take it's XP. I would try the following

Go into device manager and look for any USB conflicts or devices that could be related to the bug and remove them. The next thing to do is download the software from Pure again, in case it was corrupt in someway. I used the support link from bug.com. Now connect your usb cable to the bug and see if it picks it up automatically. Make sure the PC is on when you do this!

I can't remember if I had to point to the location where I downloaded the software or not, or if I manually kicked off the software after it was detected.

Please try it again and let me know the results. If it still does not work I will connect my bug to the PC to see what happens.

  zipdrive 17:53 15 Mar 2005

Sorry the last remark about having the PC on sounds stupid. what I meant to say is don't start the PC up with the bug connected.

  zipdrive 18:00 15 Mar 2005

Just another idea about the memory cards. Have you formatted them, have you a card reader to do this.

You get this error alot with digital cameras. Sometimes they need to be formatted in the device they are going to be used in. I have not got an SD card yet to see if they can be formatted in the bug?

  MINKS 20:30 15 Mar 2005


yes the o/s is windows xp home

Tried formatting the card on the Bug but it will not format saying again error reading card.

On plugging in the bug, In the device manager it states in the usb mass storage drive This device cannot start (code 10)

Then when update software is run we press the button on the bug to confirm usb cable is connected and in the device manager a BUG icon appears under the heading PCMCIA AND FLASH MEMORY DEVICES, this states that there is no driver installed for this equipment. Other information in the properties -




  zipdrive 20:37 16 Mar 2005

What happens if you point to the downloaded software or if you set it off manaully? I don't think I pressed any buttons on the bug.

I won't be online until the weekend now. I will plug in the bug to my PC and type up instructions on what I did to upgrade.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review

How to draw a mandala

iPhone X review

Musique en streaming : Spotify vs Deezer