Leadtek (non-existant) support

  Trisco 10:50 29 May 2003

I have been unable to get any response from leadtek regarding my graphics card - which I bought from dabs back in january.

I have been having trouble in playing any of the more modern games.such as-C&C Generals.

sometimes I can get 5 or 10 mins play but most of the time no more than a minute or two.

I sent the card back to dabs a while back and just got it back witha little note telling me that there was no fault with the card...

obviously I would like a little more than -NOT FAULTY. like what did they test it with, did they just boot up a machine or use some more graphic intensive programs ?

I sent many an email to the Leadtek support before eventually sending it back to dabs.
sent at least 5 emails to the european section of their site I even sent some to the others just trying to squeeze a response out of leadtek.

Most companies would send an automatic notification that they had recieved an email - I have had no further response from leadtek

I have now also disscovered that a Ti4200 only supports up to directX 8.1 - so does this mean that the ver9 upgrade is not required as I have installed that - would I need to re-install the older version ?

I have spent quite a bit of money trying to ressolve this and a little bit of guidance(,or dare I go so far as SUPPORT!)would have been helpful;expected and a bit less costly!!

I now have a 550W PSU two case fans and I have even bought a copper heat sink and fan for the card.


  davidg_richmond 11:24 29 May 2003

Have you tried the Helproom with your problem? You get almost instant support from any one of thousands of knowledgeable folk!

Normally to find a fault, a company would do a 'soak test', putting the card into a PC and running a game, benchmark, movie, or diagnostic test such as DirectXDiag - whichever suits the problem.

Not many boards out there support DX9, as it now includes certain advanced rendering features that require the card to do. But there is no problem if you have upgraded to DX9 - it will cause no known issues.

I would think that the issue you have would be related to your PC's configuration, but that could be found out through the Helproom. Just post in there with your OS, brand and specification of PC and a description of the problem.

  ulrich 15:12 29 May 2003

I agree go to the Helproom, I run my Leadtek 4200 on the 43.45 drivers and dx9a. Give a bit more information on your system.

  Mysticnas 16:25 03 Jun 2003

I used to a have a similar prob as you're having. I have a GF4 Ti4600 Ultra TD my vivo.

I used to play games and kept getting thrown out of the game.

this is what you need to check, ok load up winfast software and make sure the card hasn't been overclocked. just click defualt value.

ok if that doesn't help, go into display properties, setting, advanced, now if you've loaded the new nVidia drivers you should have a tab with a nVidia logo and the name of your GF4 card. in that somewhere you can change the settings for FSAA, AF etc... lower these settings.

If after that you don't get a result then it may well be that the card is dodgy.

Leadtek do take a while to reply to emails. I got a reply after 3weeks once. Last time i checked they only had 2 guys working in customer support in UK... weird isn't it??? I would suggest getting Leadtek to have a look at the card even though you purchased it from Dabs. Going straight to the manufacturer they'll be able to check propperly if there is a fualt with the card and they may even give you a newer model if it can't be repaired and they don't have any of the similar cards instock.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?