Documents 'READ ONLY' after Windows 10 install

  Peter Lanky 07:44 03 Aug 2015

When trying to open files in 'My Documents' after installing Windows 10 I get the message -

"Document file 'myfile.odt' is locked for editing by: Unknown User Open document read-only or open a copy of the document for editing"

I was initially able to solve this by seeking online help where I found the following:

Follow the steps below to grant you full access to folder.

Right-click the folder - Properties.

Security tab - Advanced.

Click Change to the right of Owner.

Enter Users into box and click OK.

Enable the checkbox Replace owner on subcontainers and objects then click Apply.

If prompted that You do not have permissions to read.. click Yes.

Completely close out of the Advanced Security Settings dialog.

Right-click the folder - Properties.

Security tab - Edit.


Enter Users into box and click OK.

Enable the Full Control checkbox then click OK.

This worked, but after closing down the PC, the next time I tried, the problem had returned.

I had the same problem with the 'Pictures' folder, and seem to have permanently sorted this by opening command prompt as administrator and typing:

attrib -r e:\Picures

However, when I try this with attrib -r e:\My Documents I get the message 'Format parameter not correct -

So I have 2 questions

1) Why is this happening?

2) How do I execute the attrib command with 'My Documents? (being 2 words)

  sunnystaines 09:41 03 Aug 2015

got the same copy file to desktop change name, delete original and put copy back that is what i have been doing.

  BA2 7HX 22:33 09 Aug 2015

You are lucky, my only solution so far is to remember to open any application with "run as administrator" it is not good. Any ideas?

  Forum Editor 19:28 13 Aug 2015

That was the only glitch I encountered when I ran the Windows 10 upgrade. All my documents had altered file permissions. It took about ten minutes to change the permissions on the folders, and all was well.

  Peter Lanky 19:30 13 Aug 2015

I'd tried that too, but after closing down and rebooting, the permissions reverted back to being Read Only.

  AndrewMarkham 21:06 13 Aug 2015

You need to create a HomeGroup on your PC, via Control Panel HomeGroup

  Forum Editor 22:36 13 Aug 2015

Peter Lanky

That didn't happen to me, everything reverted to normal once I reset the permissions. I have had no further problems of any kind.

  Forum Editor 22:38 13 Aug 2015


How would setting up a Homegroup have any effect on file permissions? I certainly didn't need to do it.

  Peter Lanky 23:22 13 Aug 2015

I've solved the problem by moving my documents back to my c:\ drive which is a SSD, but it's not how I had planned my file organisation as space is limited on this drive, only being 120GB.

  Burn-it 15:56 15 Aug 2015

Did you try "taking ownership" of the folder. That should work.

  Peter Lanky 16:55 15 Aug 2015

Yes, both as myself personally, and as administrator.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?