Crucial UK website

  Ranger 16:48 25 Jan 2003
Locked

anyone else out there having problems getting on to the crucial uk website, I have been trying for the last hour to get on with no luck

  TOPCAT® 16:55 25 Jan 2003

Probably updating the site maybe. TC.

  Djohn 16:58 25 Jan 2003

Tried just now and no probs. Give it another try.

  TOPCAT® 17:03 25 Jan 2003

Must be some feeder line trouble. TC.

  Ranger 17:05 25 Jan 2003

still can't get on, oh well I'll probably have to wait until tomorrow now

  Djohn 17:18 25 Jan 2003

click here use the com. address and click on uk from there, top left under international.

  Ranger 17:20 25 Jan 2003

Cheers DJohn, had already tried that, same result, can't get on

  'oppy 19:43 25 Jan 2003

Ive just tried it too, getting this error message..

Sorry, Not Found. 404 File Not Found Error.

--------------------------------------------------------------------------------

The URL path in your request was not found.

Please make sure that it is exactly as it should be. Also check the capitalization and that you are using forward slashes ( / ).

  Elrond 19:59 25 Jan 2003

No joy here either. Must be updating

  TOPCAT® 22:07 25 Jan 2003

Sorry. Site Temporarily Unavailable
Please check back later.

  anchor 17:24 26 Jan 2003

Working OK today:

click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?