Acer Aspire 5542 power

  gradhaingeal 13:49 14 May 2012

Hi There, I hope someone can help me!

My laptop lead does not appear to be powering my laptop. I had it plugged in and turned on but I obviously did not notice that it wasn't charging. Suddenly I had a 'please plug into a power source' notification. My battery died very soon after.

Now my laptop will not turn on at all. The LED on the little box thing on the lead is on and looks normal. I have felt all along the part of the lead from the box to the laptop and wiggled it around a bit - no difference. I have tried another power socket also.

When the lead is connected there is no light indicating its connection on the laptop itself.

When I press the power button with the battery and power lead attached it lights up for just a second before turning off. There is no response with just the lead attached.

I have tried a few suggestions that I have read about including holding the power button while holding the laptop upside down which I'm beginning to suspect was just to make me look silly! Please can someone advise me where I go from here?

Many thanks, Kate

  birdface 16:01 14 May 2012

Have you tried it without the battery.

  frybluff 22:51 14 May 2012

Sounds like an issue with battery, possibly as simply as dodgy connection. If you have local comp repair shop, they may have spare just to plug in to try. Probably will only charge nominal ammount, at least for just doing that (maybe even free, if you ask nicely, and they have one lying around). That will probably help diagnose. Take your mains charger/lead with you, to check charger at same time. You don't mention its age, but laptop batteries do have a finite life.

  onthelimit1 08:49 15 May 2012

sounds like the charger - around a tenner from Amazon/ebay.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?