You do not have Java applets enabled in browser

  FatboySlim71 20:46 18 Apr 2008
Locked

Everytime I try to visit the BT speedtest site with IE7 I get a yellow banner appear on the top of the web page saying that,

"You do not have Java applets enabled in your web browser."

I normally use Firefox but I have been getting an error at 96 percent of the way through the test.

Does anyone know how to or can anyone run the BT Speedtest through IE7?

I am running Windows Vista Ultimate.

  MAT ALAN 20:53 18 Apr 2008

To enable Java in your browser, follow the instructions below.

Internet Explorer for PC

* Click "Tools" --> "Internet Options"
* Select the Advanced Tab, and scroll down to "Java (Sun)" or to "Microsoft VM"
* Check the box next to the "Use JRE" or "Use Java 2" listing under "Java (Sun)" or to the "Java console enabled" listing under "Microsoft VM"
* Next, select the Security Tab, and select the "Custom Level" button
* Scroll down to "Scripting of Java applets"
* Make sure the "Enable" radio button is checked.
* In the section marked "Microsoft VM", if it exists, make sure that "Disable Java" is NOT selected. If it is selected, deselect it by selecting "High Safety".
* Click OK to save your preference.

  FatboySlim71 21:06 18 Apr 2008

Thanks MAT ALAN, but the "Check the box next to the "Use JRE" was already ticked, as far as the,
"Java console enabled" listing under "Microsoft VM"

I had no entry for this in Tools/Internet Options/Advanced tab.

  MAT ALAN 21:36 18 Apr 2008

click here

try the latest version,it may help...

  FatboySlim71 22:29 18 Apr 2008

I tried downloading from your link MAT ALAN but i still get the "You do not have Java applets enabled in your web browser."

  MAT ALAN 22:34 18 Apr 2008

click here

some good info here, BUT i have just been to the website you mention and it gives me the same error, so it may not be your PC but the website in question .

  MAT ALAN 22:36 18 Apr 2008

Forgot to mention i do not have any issues with any other website i visit..

XP Home SP3 Firefox..

  FatboySlim71 22:46 18 Apr 2008

I have been aware of the "You do not have Java applets enabled in your web browser." with IE7 for quite a while, possibly since I got my new PC? but I can't be certain of this. I normally just use Firefox to run the BT speedtest but often when I try to run the Speedtest it gets 96 percent of the way through the test and then nothing else happens.

  FatboySlim71 09:04 19 Apr 2008

bump

  FatboySlim71 17:15 19 Apr 2008

I think I might have sorted it. I went into Control Panel in Vista, selected additional options, Java; I then selected <APPLET> Tag support, I then ticked the box for INTERNET EXPLORER.

I have tried running the BT Speedtest several times after doing this and the problem seems to have gone away, even after the PC has been switched off.

Thanks MAT ALAN for the help it was much appreciated. I'll leave it a little longer though before I mark as resolved ;-)

  FatboySlim71 23:30 21 Apr 2008

Just to update the problem has returned.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Best of the Grad Shows 2017: University of the West of England (UWE)

Best value Mac: Which is the best £1249 Mac to buy

Les meilleures GoPro 2017