No POST (Emachines 420)

  dantyboino1 00:04 17 Nov 2006

Up until this morning my trusty emachines 420 machine worked fine, with all the standar configuration (although I recently updated the RAM - which wasn't a problem). This afternoon I powered on my PC but all I got was the following:

HDD LED Frozen on.
PSU fan on.
CPU fan off.
DVD disk drive not powered.
No display at all.
No beeps.

On examination, my DVD disk drive will work properly when the data cable is removed from it or from the motherboard. Another device on this IDE cable (my CDRW) works fine, whether connected or not.

Tried clearing CMOS, removing and replacing RAM, checking for loose objects, and removing all connected devices - the same result as above is encountered.

Any suggestions? As I say, it worked fine until recently, and crashed today - nobody has moved anything inside it before it broke ...

Cheers in advance,


  skidzy 06:54 17 Nov 2006

Faulty PSU ? / Non-compatible Ram. Though doeas sound like a faulty PSU,why this happens when just replacing the ram i have no idea at this time.Others may advise more.

  Fruit Bat /\0/\ 09:18 17 Nov 2006

Check IDE controllers (BIOS) do both drives show?
and drive jumpers may be an IDE cable fault if OK without DVD attached

  dantyboino1 09:51 17 Nov 2006

I'll check the PSU when I return home later ... Wish me luck!

It can't be a non-compatible RAM issue, it's been working fine since the upgrade for about 3 weeks (and the PC recognised and used the RAM)

How would I get into the BIOS when there's no display? There's absolutely nothing on the screen (the monitor says that it's not recieving a signal - as it would if the PC was powered off)

I've a few PSUs going spare from older projects in the house ... Hopefully I can shed some light on the matter.

  Fruit Bat /\0/\ 11:06 17 Nov 2006

Sory misread your post I thought the machine was woking properly with the DVD drive disconected from the ribbon cable.

Certaily sounds like a PSU problem or something dragging down the PSU voltage.
Try disconnecting DVD / CD / HDD power cables and see if it will boot to an error message like "no op system /no drive insert system disk".

  User-312386 11:14 17 Nov 2006

It could be your CPU fan has either stopped working or is so grubby with dust the PC will not boot

  dantyboino1 21:58 17 Nov 2006

I'll test in realtime ... Testing on machine, typing findings as I get them.

Here goes:

Test 1: Using a different (working) IDE cable.
Result unchanged. DVD drive still not operating.

Test 2: Switching the cables around for DVD drive and CDRW Drive.
Result: Unchanged. No output on DVD Drive, output on CDRW drive.

Test 3: Removing IDE cable - IDE for Mobo>DVD(slave)>CDRW(Master)
a) removing from mobo
Result: DVD drive/CDRW drive fully functional (exception to the fact that the mobo wont recognise them, now)

b) removing from DVD drive (leaving mobo and CDRW connected)
Result: DVD/CDRW drives fully functional (of course, mobo wont recognise the DVD drive as it's disconnected.

c) removing from CDRW drive. (leaving the other devices connected)
Result: Unchanged. DVD drive still not functional, no boot.

Test 3: Unpowering devices
a) unpowering CDRW drive
Result: CDRW drive not working (obviously). Rest unchanged
b) unpowering DVD drive
Result: Unchanged.
c) unpowering HDD
Result: No frozen on HDD light. Rest unchanged.
d) Unpowering processor fan
Result: Unchanged

Test 4: Removing RAM (one stick at a time for testing purposes)
Result: unchanged (on both instances)

This test in in response to arogue dialler I had (which caused a lot of clicking inside)
Test 5: Removing network card
Result: Unchanged.

Test 6: Changing PSU
Result: Looks like I found it ... Lol I'll post back 10 minutes

  dantyboino1 22:06 17 Nov 2006

OK on further checking ... I'm missing a a cable on my new PSU it has 4 pin slots and connects directly to the motherboard in a sort of square connection


Kinda looks like that ... But the dots are in the middle lol. The two || symbolise the clip, and the [.] are the pin slots.

Is this vital to the machine's operation? Seems to work fine without it but I don't wanna fry my PC lol

  dantyboino1 22:07 17 Nov 2006

The clip in the diagram is central, not to the left. Forum's scripting musta moved my spaces out.

  dantyboino1 22:16 17 Nov 2006

Further analysis:


PSU worked fine without the DVD drive connected via IDE (everything else was fine, too) - I powered and IDE'd the DVD disk and powered on: BAM!

Second PSU burned down ... FFS STUPID DVD drive.

Ah well I got two more ;) I'll go get one now and try again.

  dantyboino1 22:28 17 Nov 2006

Hmmm ... OK maybe not. It WAS working fine ... Now, nothing =\ I've replaced the PSU (again) only leaving it to the same way it was in the first place.

Back to square one?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review

How to draw a mandala

iPhone X review

Les meilleures enceintes Bluetooth à moins de 150 euros