waspie 21:41 13 Dec 2005

I am trying to establish a LAN with my Ibook and PC. I currently have them both hooked up to a Netgear Router, the router connected to a bt voyager ADSL modem (2Mb). Both Mac and PC can access the net at the same time but neither can see each other.
Mac OS is ver10.4, PC is XP Pro with SP2.

Also in the equation is a apple airport which allows me wireless access to the net, this also works.

Any help would be appreciated. Oh yes, can you keep it fairly simple.

  mgmcc 09:12 14 Dec 2005

Firstly, computers in a Windows network need to be in the same "Workgroup", so you need to give the Mac the same Workgroup name as you use with the PC.

In Finder, go to "Go > Utilities" and open "Directory Access". In the Services tab, double click "SMB/CIFS" and a box opens in which you can enter the Workgroup name.

Now go to "System Preferences" and, in the "Internet & Network" section, select the "Sharing' applet. In there, I have "Personal File Sharing" and "Windows Sharing" enabled.

That should be it as far as the Mac side is concerned. Are you familiar with the Windows side?

When accessing the Mac from Windows, you will be prompted for your Mac Username and Password, but XP Pro should remember these login details, XP Home doesn't.

  waspie 15:06 14 Dec 2005

Thanks mgmcc, done the above on the mac and I get mshome and my network folders appear. But still no sign of the windows pc.

The xp pro pc in Network Places shows itself but still no sign of the mac.
I'm a bit of a dummy when it comes to networking. I have literaly gone over the system, checking physical connections, correct cabling etc. I even uninstalled the DSL, re-installed to ensure the correct proceedure was followed. At best at least both machines can access the net simultaniously, it would be nice to have them capable of exchanging data.

If anybody has any clues I am willing to try anything. Thanks again for all you assistance.

  mgmcc 20:05 14 Dec 2005

In the Windows PC, make sure you have at least one folder set as "shared" in its Properties (by right clicking and selecting the Sharing & Security option). Any firewall software needs to be configured to allow access to the Mac, which is normally done by entering its IP address in the "trusted" area.

In the Mac, from the Finder menus select "Go > Connect to Server". In the box that opens, for the Server Address, enter:

smb://{computer name}

replacing {computer name} with the actual name of the Windows PC in your network. Alternatively, enter smb:// followed by the IP address of the Windows PC. You should then have the option of which shared folder in the Windows PC to access.

In the Windows PC, if you cannot see the Mac in "My Network Places", try entering its name followed by your Username in the address bar. For example, I have a MacMini (named MacMini) and my Home folder is 'Mike' so I can enter:


to access my Mac's folders. Again, I can access it by entering its IP address, in my case:


  waspie 21:36 14 Dec 2005

50% of the way there, I have the ibook reading shared docs folder on the PC thanks to your assist but not the other way.

I worked through the "My Network Places" bit but am still unable to get XP to recognise my Mac. One thing that confuses me a little, when searching for the mac's IP address I couldn't for the life of me find any address in the 192.168.?.? area. It showed and mention of a sub net mask if this is any help in the tcp/ip tab.

Really grateful for your help mgmcc, you have saved me a load in paracetemol today.

  mgmcc 22:22 14 Dec 2005

<<< when searching for the mac's IP address I couldn't for the life of me find any address in the 192.168.?.? area. It showed and mention of a sub net mask if this is any help in the tcp/ip tab. >>>

That's fine. There are several IP address ranges which are reserved for use with Local Area Networks, the most commonly used being 192.168.x.x, but the 10.x.x.x range is also used and, if your router operates in that range this isn't a problem. Make sure that your Windows PC also has an address in the range and with the Subnet Mask

I *don't* have the firewall enabled in the Mac, so if you do, try disabling it to see if Windows can find the Mac.

If you go into "System Preferences > Sharing" and highlight Windows Sharing in the Services tab, it should actually say "Windows users can access your computer at \\\{name}"

  waspie 06:41 22 Dec 2005

I have given up. I can get the Mac to see the PC but not vica versa. I have spoke to BT and Apple.
Most useful advice has been from mgmcc.

Thanks for all your advice and aid. I think I will settle for 2 seperate units. I have most of the data I wished to see/read on the PC now transfered onto the mac via CD.

Thanks again mgmcc.

  ajm 19:43 25 Dec 2005


  powerless 01:38 26 Dec 2005

I'm sure if you look at this topic again, you'll find something you haven't done or overlooked as there are a few things mentioned.

The first thing is to make sure that both PC and Mac are on the same workgroup.

On the Mac as mgmcc said it's under: *Directory Access* - Just use Spotlight and type "dir" it'll pop up under spotlight in a flash.

Click: Configure

Then Click: SMB/CIFS - and when the window pops up make sure the workgroup name is correct.

[if you can't access smb/cifs click the padlock on the window to allow changes to be made and you'll have to supply the password to do this]

click here


Next open up: *Sharing* - Just use Spotlight and type "shar" it'll pop up under spotlight in a flash.

Click the box next to: Windows Sharing

The service should now start and at the bottom there should be something like:

*Windows users can access your computer at \\\chris*

click here


Now open up: *Finder*

Now Click: *Network* [left, top]

On My Mac Mini I see a folder called: *workgroup* and double clicking this allows me to see the names of my PC's.

click here

Double clicking one of them starts a connection and i have to authenticate myself [Windows User account password].

click here

You then have to specify want you want access to....and then i can see my PC from my Mac.

click here

Then clicking [top, left]: *Network (F)* shows me my windows share.

click here


Or just view the video: click here


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?