btsendto_office.dll macro warning on Excel startup

  all4one 20:05 21 Apr 2006

I usually have Excel security set at high, but from time to time I need to run spreadsheets with a macro. If I set security to medium, the next time I start up Excel - before book1 loads - I get a macro warning that C:windows\system32\btsendto_office.dll contains macros and do I want to enable/disable. What is this and how can I stop it? Thanks to anyone who can help.

  VoG II 20:08 21 Apr 2006

Go to Tools > Add-ins and untick btsendto_office.

  all4one 20:14 21 Apr 2006

Thanks VoG, but my Add-ins does not list btsendto_office

  VoG II 20:22 21 Apr 2006

Do you have any bluetooth software like click here installed?

  all4one 20:31 21 Apr 2006

VoG, I have MSI bluetooth version 1.4

  VoG II 20:41 21 Apr 2006

In Excel, Tools, Options, General tab. Is there an entry in 'At startup upen all files in' ?

  all4one 21:04 21 Apr 2006

No entry in 'At startup open all files in'

  VoG II 21:15 21 Apr 2006

Hmm. I can see that this is not going to be straightforward.

Ensure that you can see hidden files and folders:

1. Click Start.
2. Click My Computer.
3. Select the Tools menu and click Folder Options.
4. Select the View Tab.
5. Under the Hidden files and folders heading select Show hidden files and folders.
6. Click Yes to confirm.
7. Uncheck the Hide file extensions for known file types.
8. Click OK.

Make sure Excel is not running. Now use Windows Explorer to navigate to C:\windows\system32 and rename btsendto_office.dll to oldbtsendto_office.dll (or indeed anything).

Start Excel - it will almost certainly complain that it cannot find a file. Close Excel then re-open it. Hopefully the messages will be gone - hopefully!

  all4one 22:01 21 Apr 2006

Tried that. Even changed some of the other btsendto dlls and also rebooted after change, but same message appears on Excel start up. Do you think I should try to unload and reload the Bluetooth software?

  VoG II 22:14 21 Apr 2006

Before you do that (which is a sensible suggestion), try setting Excel's security to Low and check that the error message disappears.

Unless you are in the habit of opening Excel files from unknown sources, this will not seriously compromise your security.

The alternative would be to edit the registry but I'm afraid that I could not advise which keys to remove to stop the message yet retain your bluetooth functionality.

  all4one 22:18 21 Apr 2006

Really appreciate your help VoG. I'll do that and try unload reinstall - but think I'll wait until tomorrow. I'll post an update

Thanks again

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017